1. Simple Image Gallery
  2. Friday, 07 September 2012
Please help. I tried implementing the Simple Image Gallery Module but when I try to view it on my website it comes up with the following errors:


Warning: mkdir() [function.mkdir]: Permission denied in /home/neoninfote/domains/neoninfotech.com/public_html/Website/modules/mod_sp_simple_gallery/helper.php on line 54

Warning: imagejpeg() [function.imagejpeg]: Unable to open 'images/sampledata/fruitshop/thumbs/apple.jpg' for writing: No such file or directory in /home/neoninfote/domains/neoninfotech.com/public_html/Website/modules/mod_sp_simple_gallery/class.spThumbnail.php on line 122

Warning: mkdir() [function.mkdir]: Permission denied in /home/neoninfote/domains/neoninfotech.com/public_html/Website/modules/mod_sp_simple_gallery/helper.php on line 54

Warning: imagejpeg() [function.imagejpeg]: Unable to open 'images/sampledata/fruitshop/thumbs/bananas_2.jpg' for writing: No such file or directory in /home/neoninfote/domains/neoninfotech.com/public_html/Website/modules/mod_sp_simple_gallery/class.spThumbnail.php on line 122

Warning: mkdir() [function.mkdir]: Permission denied in /home/neoninfote/domains/neoninfotech.com/public_html/Website/modules/mod_sp_simple_gallery/helper.php on line 54

Warning: imagegif() [function.imagegif]: Unable to open 'images/sampledata/fruitshop/thumbs/fruits.gif' for writing: No such file or directory in /home/neoninfote/domains/neoninfotech.com/public_html/Website/modules/mod_sp_simple_gallery/class.spThumbnail.php on line 122

Warning: mkdir() [function.mkdir]: Permission denied in /home/neoninfote/domains/neoninfotech.com/public_html/Website/modules/mod_sp_simple_gallery/helper.php on line 54

Warning: imagejpeg() [function.imagejpeg]: Unable to open 'images/sampledata/fruitshop/thumbs/tamarind.jpg' for writing: No such file or directory in /home/neoninfote/domains/neoninfotech.com/public_html/Website/modules/mod_sp_simple_gallery/class.spThumbnail.php on line 122


They look to me like a pathfile error. Is this related to my Joomla install or is it a problem in the module itself? If anyone can give me some suggestions on rectifying it that would be great.

If you want to see the problem live on the site, the URL is:
http://neoninfotech.com/Website/index.php/en/company/about-us/photo-gallery

With the login being: Intergraph and the password being: testsite

Thanks a lot :)
Responses (6)
Please check your folder permission (755).
  1. more than a month ago
  2. Simple Image Gallery
  3. # 1
Hi, thanks so much for your reply but can you please clarify how I go about changing the permission to 755?
  1. more than a month ago
  2. Simple Image Gallery
  3. # 2
Ok, I think I've worked out how to change it. Next question, which folders need to be changed? Currently it looks like all the folders are 755, but the files are not. Does that sound correct?
  1. more than a month ago
  2. Simple Image Gallery
  3. # 3
The folder you set from the module parameter.
  1. more than a month ago
  2. Simple Image Gallery
  3. # 4
Hi, so the permissions for that folder are currently set to 755 (drwxr-xr-x).

Because I was having issues with the sample pictures, I decided to upload some other pics to a new folder. Now when I select that folder in the module settings I don't get the errors, which is nice, but it also doesn't load up any images. It essentially just creates a blank module.

I took a look in the folder and it hasn't created any thumbs, so the function clearly still isn't running.

I'm using Joomla 2.5.
  1. more than a month ago
  2. Simple Image Gallery
  3. # 5
Then manually create a thumbs folder in that directory.
  1. more than a month ago
  2. Simple Image Gallery
  3. # 6


There are no replies made for this post yet.
Be one of the first to reply to this post!


This forum is archived

This forum has been archived. Please use JoomShaper official support system.