1. SP Page Builder 3.x
  2. Thursday, 11 June 2020
When I try to go into the front end editor, I get an error - Unclosed string at position: 2784.
I have tried disabling JS Compression as suggested in a previous question, but still have this issue.
I have disabled JCH and purged all caches as well
Accepted Answer
I fixed today site with Helix3, all I've done was: disabled JS compression from Helix settings, clean Joomla cache in case of.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # Permalink
Responses (16)
Hi Mr. Frankowski,

for me it works, thank you:)
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 1
(Following…)
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 2
Hi,
disable CSS and JS compression from Helix Options

work it for me
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 3
you need to find the JS file that is causing a conflict, and exclude this form JS caching. validate.js and punycode.js works for me.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 4
same issue observed on my sites : websites which used to work fine before have their Contact Form throwing that error message.

Since I guess it concerns all your users, I guess/hope/suppose that you will come with a fix ;)

We also start to have people reporting the issue on the official French-speaking forum : forum.joomla.fr
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 5
For Helix3 we recommend using the JCH_Optimizer plugin (or similar).
---
Helix Ultimate in next 2-3 weeks will get a big upgrade, which also speeds up this template
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 6
Hi,
disable CSS and JS compression from Helix Options


Don't you need these compressions enabled for faster page loads? Is there an alternative?

Thank you for being super!
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 7
Now I'm getting "Unclosed string at position: 2784" again with a component pointing to my contacts. I suspect pagerbuilder is interfering.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 8
OK got it to work this time. Not sure why it didn't work last time - think it was probably an issue with Siteground memcacher not fully purging, but just a guess.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 9
I have the Same Issue after updating to ver. 3.7.3.
I uninstall the Component and install it again. Before I disable CSS and JS compression from Helix Options
After that I can use the frontend editor without the Error.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 10
In that case, I need access, but I hope you know, it's weekend = No access to developers (!)
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 11
Hi,
disable CSS and JS compression from Helix Options


I already tried this, along with purging the caches, and still have the error.

Unrelated, but I've also noticed that JCH has stopped working with SP Pagebuilder as well.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 12
Since I restored my previous Joomla installation the 404 hoop was "Component not found" but I can still edit the page.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 13
After I updated to Joomla 3.9.19 I also received "Unclosed string at position: 2784"
I also disabled CSS and JS compression with the HelixUltimate>Template Options>Advanced Setting.

No change--unable to use PageBuilder from the frontend.

Before the update I could edit using Pagebuilder from the frontend but had to jump through a 404 hoop.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 14
Hi,
disable CSS and JS compression from Helix Options
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 15


There are no replies made for this post yet.
Be one of the first to reply to this post!


This forum is archived

This forum has been archived. Please use JoomShaper official support system.