1. SP Medical
  2. Tuesday, 14 January 2020
https://mrkr.io/s/5e1e492659ddcc1141c86c8c/0

As you can see from the link above, I would like this section to be shown by languages. However, it seems not working properly. It shows both English and Chinese.

In addition, if you click the "VIEW MORE" button, the new page opened will be displayed by languages. This is quite confusing.

Could you please take a look for me?

I have created an admin account for you to test but I can't expose it in public. Please let me know how can I give it to you?

Thank you.
Accepted Answer
Hi there,

Thanks for your PM. Please follow the instructions.

/modules/mod_spmedical_services/helper.php

Add this line of code
https://prnt.sc/qxv2iy

$query->where('language in (' . $db->quote(JFactory::getLanguage()->getTag()) . ',' . $db->quote('*') . ')');


-Thanks
  1. more than a month ago
  2. SP Medical
  3. # Permalink
Responses (5)
Hi there,

Thanks for contacting us. Please click on the profile name or photo, you will get a send message button. Provide me the FTP access & Joomla administrator access.

-Thanks
  1. more than a month ago
  2. SP Medical
  3. # 1
Hi there,

You have created 8 departments & one Chinese department. If you go read more from the English version, then you will get the English versions departments. Same way if you go select the Chinese language and if you go to the more options, then you will get Chinese departments. But, Home page departments add-on has a problem. Give me server access via PM. I will fix it.

https://prnt.sc/qq2ind

-Thanks
  1. more than a month ago
  2. SP Medical
  3. # 2
Hi there,

Thanks for your PM. Please follow the instructions.

/modules/mod_spmedical_services/helper.php

Add this line of code
https://prnt.sc/qxv2iy

$query->where('language in (' . $db->quote(JFactory::getLanguage()->getTag()) . ',' . $db->quote('*') . ')');


-Thanks



It works now. Thank you for your great help.
  1. more than a month ago
  2. SP Medical
  3. # 3
Hi there,

Thanks for your PM. Please follow the instructions.

/modules/mod_spmedical_services/helper.php

Add this line of code
https://prnt.sc/qxv2iy

$query->where('language in (' . $db->quote(JFactory::getLanguage()->getTag()) . ',' . $db->quote('*') . ')');


-Thanks



It works now. Thank you for your great help.


Hi there, You are most welcome & Thanks
  1. more than a month ago
  2. SP Medical
  3. # 4


There are no replies made for this post yet.
Be one of the first to reply to this post!


This forum is archived

This forum has been archived. Please use JoomShaper official support system.