1. Corporex
  2. Thursday, 02 July 2015
I built a website leveraging the Corporex template (with Quickstart) in a testing environment (hosting space on Dreamhost.) After the client's approval, I migrated the website (backup using Akeeba and install via Kickstart) to the client's hosting space on GoDaddy.

The site is fully functional, except that the Template Manager, namely the Layour Builder, does not allow me to save, close, or utilize any of those buttons.

I have done a global-checkin, cleared and purged cache, and done a "hard refresh" (shift-CMD-R on Mac).

I cannot eliminate the problem. Please help!
Accepted Answer
Hi Jason,

Please go to 'plugins\system\helix\js\admin\layout.admin.js' and on line 143 just remove ' return false;' or replace 'false' with 'true'. See how it goes.

Regards,

Alex
  1. more than a month ago
  2. Corporex
  3. # Permalink
Responses (15)
Thanks Alex! Fixed it. Javascript incompatibility with Joomla v3.4.2?
  1. more than a month ago
  2. Corporex
  3. # 1
You are welcome, Jason.
Jason Finn wrote: ... Javascript incompatibility with Joomla v3.4.2?
Sorry I can not comment for you on this as I am not a developer.

Have a nice weekend and all the best.

Regards,

Alex
  1. more than a month ago
  2. Corporex
  3. # 2
I am also having the same problem. Even after commenting the line
'plugins\system\helix\js\admin\layout.admin.js' and on line 143 just remove ' return false;
Save , Save & Close and Close buttons are not working.
Could you please share the fix?
  1. more than a month ago
  2. Corporex
  3. # 3
@Maneesh,

You should not comment out the line 143, - please keep it and just delete the "return false" argument.

Regards,

Alex
  1. more than a month ago
  2. Corporex
  3. # 4
Alex Smirnov wrote:

@Maneesh,

You should not comment out the line 143, - please keep it and just delete the "return false" argument.

Regards,

Alex

@Alex,
Thanks for the tip. It is working now.
  1. more than a month ago
  2. Corporex
  3. # 5
Jason Finn wrote:

Thanks Alex! Fixed it. Javascript incompatibility with Joomla v3.4.2?


Hi Jason, can you share how you fixed it? I have the same problem.
Thank you!
  1. more than a month ago
  2. Corporex
  3. # 6
Alex,


I'm having the same issue. Can you give me dummies guide on how I can edit 'plugins\system\helix\js\admin\layout.admin.js' as suggested plea
  1. more than a month ago
  2. Corporex
  3. # 7
@Andy Green,

The simplest way for you to edit the /plugins/system/helix/js/admin/layout.admin.js file is to FTP onto your web-site, download the layout.admin.js file, edit it in Notepad and then upload it back into /plugins/system/helix/js/admin/ folder.

If this still sounds a bit over the top, please don't hesitate to let me know and I will more than happy to further break it down to smaller steps for you.

Regards,

Alex
  1. more than a month ago
  2. Corporex
  3. # 8
Hi Alex,

I had the same problem and followed what you said ('plugins\system\helix\js\admin\layout.admin.js' and on line 143 just remove ' return false;). Now I'm able to save/close the template.

But now I have a blank page in the frontend where the template is assigned. Help please ???

Thanks
  1. more than a month ago
  2. Corporex
  3. # 9
Hi Tyner,
Tyner wrote: ...But now I have a blank page in the frontend where the template is assigned...
I believe you already created a thread to deal with the blank page issue at http://www.joomshaper.com/forums/frontend-blank-page-after-save-close-buttons-issue-resolved where our Tofiq is working with you. If future please refrain from cross posting the same issue in more than one forum thread. Many thanks in advance for your understanding.

Regards,

Alex
  1. more than a month ago
  2. Corporex
  3. # 10
Hello,

I have the same problem, with Helix 2 v2.1.8, NewsPlus template. I have updated the line as mentioned, but the problem remains...

please help. thanks.
  1. more than a month ago
  2. Corporex
  3. # 11
@ Gustavo Fadel,

Could you please PM me your site URL and its Joomla super user credentials to have a look around?

Regards,

Alex
  1. more than a month ago
  2. Corporex
  3. # 12
@Alex

I am having the same issue on every single site on Helix after Joomla 3.5.0 update. Editing 'plugins\system\helix\js\admin\layout.admin.js' doesn't help with some of them. Is there any other possible solutions for this?

Another common issue after updating to 3.5.0 is that clicking on logo does not directs to the homepage. It just refreshes the same page.

Looking for solutions for these issues. Thanks for you help in advance.
  1. more than a month ago
  2. Corporex
  3. # 13
@Ozan,

Please open up your own thread for each website with whatever issue your particular website might have and we will be happy to have a look at them one by one for you. Many thanks in advance.

Regards,

Alex
  1. more than a month ago
  2. Corporex
  3. # 14


There are no replies made for this post yet.
Be one of the first to reply to this post!


This forum is archived

This forum has been archived. Please use JoomShaper official support system.