1. Simon Logan
  2. SP Page Builder 3.x
  3. Monday, 13 May 2019
Looks like a recent update is forcing all edits for SPPB modules through the frontend via an "Edit with SP pagebuilder" button which might be good for ease of editing, however the routing doesn't seem to work properly with sh404SEF installed.

When I click on that button to edit the module I get a Page Not Found error, the same as when we try to edit or preview a page from the backend with sh404SEF enabled.

Since it looks like we are being pushed to edit through the frontend this therefore means any SPPB modules are now uneditable?
Responses (4)
Accepted Answer Pending Moderation
Hi,

In development time please turn off sh404SEF when website is fully developed then turn on sh404SEF. Also we will try to solve this issue in future.

Thanks,
Mamun
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 1
Accepted Answer Pending Moderation
Hi Mamun

Thanks for the response, we can take this approach for a couple of sites but for others this wouldn't be practical since they are constantly being edited and worked on by various people.

Are you able to confirm the version which moved editing from the module manager itself to the frontend and I can perhaps just roll back to that for some clients just now? Either that or would it be feasible for me to use module layout overrides to do this?

FYI there is, and always has been, an issue with SPPagebuilder routing from the backend to frontend pages (ie when clicking on PREVIEW or FRONTEND ENDIT in the admin area) when sh404SEF is used, is there a way to resolve this in general?
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 2
Accepted Answer Pending Moderation
Hi Simon,
Thanks, You know provided solution is temporary.

3.4.9 comes with module frontend edit option so use 3.4.8 to bypass that.

In general there is no other way to solve this problem. :( Also that plugin help desk I saw this issue. You check that issue.

Thanks,
Mamun
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 3
Accepted Answer Pending Moderation
In tomorrow update (3.6.4) it should be corrected but remember about this setting

sh404SEF.png
Attachments (1)
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 4


There are no replies made for this post yet.
Be one of the first to reply to this post!


This forum is archived

This forum has been archived. Please use JoomShaper official support system.