1. News Show SP2 (module, not addon!)
  2. Friday, 10 May 2013
SP2 is missing the code required for using suffixes,bootstrap span & bootstrap offset's. Please change line 39 in the tmp/default.php file from
<div id="ns2-<?php echo $modId; ?>" class="nssp2 ns2-<?php echo $uniqid ?>">

to
<div id="ns2-<?php echo $modId; ?>" class="nssp2 ns2-<?php echo $uniqid . $params->get( 'moduleclass_sfx') . " span".$params->get( 'bootstrap_size' ); ?>">

with will enable both offset's and spans.
This works in Joomla 3.1 and should work in all versions of J! that support bootstrap.
For 2.5 simply make it
<div id="ns2-<?php echo $modId; ?>" class="nssp2 ns2-<?php echo $uniqid . $params->get( 'moduleclass_sfx');  ?>">
instead since it doesn't have the bootstrap_size param by default.
Responses (2)
also where is $uniqid coming from? I don't see that it was declared before being called.
We will add within the next release. Thanks for informing.
Uniqid is module id that is declared in the mod_news_show_sp2.php file.


There are no replies made for this post yet.
Be one of the first to reply to this post!


This forum is archived

This forum has been archived. Please use JoomShaper official support system.