1. Joel M.D
  2. SP Page Builder 3.x
  3. Thursday, 14 November 2019
If I try to click on the Frontend Edit Button (Backend),
it opens an empty website, URL is also wrong.
Attachments (1)
Responses (26)
Accepted Answer Pending Moderation
Hi,
ask hosting support, I see problem with IP & DNS
---
Remember about this setting too
sh404SEF.png
Attachments (1)
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 1
Accepted Answer Pending Moderation
Hi Paul,

today i installed SPP Update and setup SH404SEF as you said but it doesnt work.
SPP try to open https://edit/98
Please help. Site: http://www.itc-solution.de
Thanks,
Raphael
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 2
Accepted Answer Pending Moderation
It didnt helped me as well, have same problem as
Rapha73. Didn't had it before.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 3
Accepted Answer Pending Moderation
We are checking why in some cases helped and in others not,
but we need access (Super User) to the website to check deeper.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 4
Accepted Answer Pending Moderation
sent PM
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 5
Accepted Answer Pending Moderation
@Rapha73
Sorry, I don't know, something is blocking sppb javascript files from loading.
It's possible for you to:
a) On this same hosting & server settings, create a subdomain
b) Install there a raw Joomla, and install Helix template and SPPB Pro
c) and test with testing Page front-end edition

It will tell us - if this is server security settings OR additional extension.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 6
Accepted Answer Pending Moderation
Today our developer said:

Yes, I confirm that there is still an issue with sh404SEF in some cases only. We are working on it next will fix the issue in the next update.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 7
Accepted Answer Pending Moderation
... We are working on it next will fix the issue in the next update.
Nothing fixed! I get always the same answer from Al Mamun. We will fix it in next update.

Why you don't do that?

Raphael
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 8
Accepted Answer Pending Moderation
Are there any news about this problems with sppagebuilder and sh404sef.
Yes i already set all the options that you mentioned but still have problems.
When i create a new page Tab Pagebuilder and set it to a menu.
Then the link roots always to .../sppagebuilder > 404
Especially when i click on Frontendediting

Can't Joomshaper contact weeblr to work together just for this failure for the customers of both
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 9
Accepted Answer Pending Moderation
I also have still the same problem.
The solution didn't solved the problems
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 10
Accepted Answer Pending Moderation
Jommshaper Blog from 14.09.19 SP 3.6.4

Full changelog of SP Page Builder 3.6.4 Pro

New: Introduced the Image Carousel addon
New: Added 4 new carousel blocks to block collection
Fix: Frontend edit 404 issue with sh404SEF

https://www.joomshaper.com/blog/brand-new-image-carousel-addon-arrives-in-sp-page-builder-pro

....SH404 issue not fixed!

per private message i become many mails. We will fix it at next version.....


..but nothing fixed since many months

:(
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 11
Accepted Answer Pending Moderation
now we have V3.6.8 .....aaaaand NOT FIXED!


no support here!
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 12
Accepted Answer Pending Moderation
Sorry, indeed.
But if you have SH404 PRO -- can you ask their support about any clues?
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 13
Accepted Answer Pending Moderation
I'm having the exact same problem:(
Nothing works for me
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 14
Accepted Answer Pending Moderation
What about
weeblr.com/helpdesk
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 15
Accepted Answer Pending Moderation
the problem is also at my side when i click on preview it roots to /sppagebuilder and this doesnt work

i have posted a ticket on the weeblr page

lets see what they write
but its very bad that now no new page could be made with pagebuilder and this is not good for either Joomshaper and weeblr.
So i hope you two could work together so your both customers can be helped.

If they ask where to contact someone responsible what would be the best way?
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 16
Accepted Answer Pending Moderation
all that have that failure
Can you please click in backend >sppageuilder Tab>Pages on a page on the >Preview Button please
Does it work for you or do you get a wrong page?
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 17
Accepted Answer Pending Moderation
it used to miss adding http://www.mywebsite.com in the link

however , now i have disabled the sh404sef component and the links are good now but it is stuck at loading the page
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 18
Accepted Answer Pending Moderation
Unbelievable

Should i post some PM from you Paul and Al Mamun?

Since months you tell me that DEV has found problems in SPP and will fix it.

Now you say go to weeblr.com?

Very bad support!!! :(
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 19
Accepted Answer Pending Moderation
Hi Paul,

do you rember last year?
Attachments (1)
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 20
Accepted Answer Pending Moderation
Very sad.

But guys, I have a temporary solution for you, I use. Create a Login form in your Mainmenu. Log in at the frontend. Then, if you use a Joomshaper Template, you should be able to see on frontend the "Edit Page" button.

It's kind of tricky, not comfortable at all, but better than not having any change to edit from frontpage.

BUT: Dear supporter (Paul), I dont want to keep always a frontend Login Form on my Website, or being forced to switch it on and off, just to work on the website.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 21
Accepted Answer Pending Moderation
P.S. Please even after now I gave a temporary solution, don't mark this Thread as "Solved" cuz it is not!
Sh404sef is still not compatible
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 22
Accepted Answer Pending Moderation
Create a Login form in your Mainmenu. Log in at the frontend.

You can simply enable shared sesions in general joomla settings instead. Then you do not need a login form in the Mainmenu.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 23
Accepted Answer Pending Moderation
What happens when you are in Backend>SPPageBuilder>Pages and you click on Preview?
Does this work when sh404sef is on or off?

I have written with weeblr support (sh404sef) and the advice given from Joomshaper to turn the option in sh404sef>settings>components>sppagebuilder to joomla router is not got (sh404sef tells it)
it should be like in the attachment. Thats the advice given by the developer.

Please let me know what happens when turning off sh404sef (and clear cache) if the Preview and Frontend button works and please also try turning on again and report all ways
thanks
i give the feedback to the dev team
Attachments (1)
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 24
Accepted Answer Pending Moderation
Hi
The support from weeblr provided a fix for this problem

Here is a step by step list to fix it
1. get the latest version of sh404sef (you can get a dev Version/soon they will bring an official new version but this dev version from the link fixes the problem Dev Download sh404sef and install it
2. make sure in settings> sh404sef> components> sppagebuilder is set to use sh404sef router (above i have added a screenshot so you can see this setting. Its very important to set it this way as mentioned by the developer of sh404sef!
3. then delete all sppagebuilder pages that are collected in the sh404sef> SEF Urls (no worry they come back later)
4. turn off sh404sef & save and turn on again (i did this it was not adviced by the developer)
4. Clear cache
5. visit the pages so they appear again in sh404sef> SEF Urls
6. try the Preview and Front end Buttons
7. Now everything should be fixed

It did work for me at two pages on different servers

Please give Feedback if it also did work for you

Thanks
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 25
Accepted Answer Pending Moderation
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 26


There are no replies made for this post yet.
Be one of the first to reply to this post!


This forum is archived

This forum has been archived. Please use JoomShaper official support system.