1. Doctor
  2. Monday, 14 November 2016
As described in the title.
Accepted Answer
I've found a solution for this issue now by myself.

I've commented out lines 32-76 on "main.js":

// Select
$(document).on('click', function(e) {
var selector = $('.sp-select');
if (!selector.is(e.target) && selector.has(e.target).length === 0) {
selector.find('ul').slideUp();
}
});

$('select').each(function(event) {
$(this).hide();
var $self = $(this);
var spselect = '<div class="sp-select">';
spselect += '<div class="sp-select-result">';
spselect += '<span class="sp-select-text">' + $self.find('option:selected').text() + '</span>';
spselect += ' <i class="fa fa-sort-down"></i>';
spselect += '</div>';
spselect += '<ul class="sp-select-dropdown">';

$self.children().each(function(event) {
if($self.val() == $(this).val()) {
spselect += '<li class="active" data-val="'+ $(this).val() +'">' + $(this).text() + '</li>';
} else {
spselect += '<li data-val="'+ $(this).val() +'">' + $(this).text() + '</li>';
}
});

spselect += '</ul>';
spselect += '</div>';
$(this).after($(spselect));
});

$(document).on('click', '.sp-select', function(event) {
$('.sp-select').not(this).find('ul').slideUp();
$(this).find('ul').slideToggle();
});

$(document).on('click', '.sp-select ul li', function(event) {
var $select = $(this).closest('.sp-select').prev('select');
$(this).parent().prev('.sp-select-result').find('span').html($(this).text());
$(this).parent().find('.active').removeClass('active');
$(this).addClass('active');
$select.val($(this).data('val'));
$select.change();
});
// End Select
  1. more than a month ago
  2. Doctor
  3. # Permalink
Responses (7)
Hi, I would request to you that, please contact with rsformpro extension provider. Thanks
  1. more than a month ago
  2. Doctor
  3. # 1
That's not a bug with RSForm!Pro. In all other templates the component works perfect.
This happend only in "doctor" template.
  1. more than a month ago
  2. Doctor
  3. # 2
FEEDBACK from RSJoomla!:
..you will notice that the RSForm!Pro select box is actually hidden and replaced by a custom <div> container, thus, this is the main reason why the Conditional Fields feature is not triggered. In this case, please contact your template developers regarding this matter, they should be able to provide further assistance and most likely they will need to add an exception for how the RSForm!Pro's dropdown fields are triggered.
  1. more than a month ago
  2. Doctor
  3. # 3
farew wrote:

That's not a bug with RSForm!Pro. In all other templates the component works perfect.
This happend only in "doctor" template.


Hi, Thanks for your reply. Please check make default joomla template & let me know. Thanks
  1. more than a month ago
  2. Doctor
  3. # 4
Toufiq wrote:

farew wrote:

That's not a bug with RSForm!Pro. In all other templates the component works perfect.
This happend only in "doctor" template.


Hi, Thanks for your reply. Please check make default joomla template & let me know. Thanks


I've already checked that, see my other answer (RSJoomla Feedback).
  1. more than a month ago
  2. Doctor
  3. # 5
farew wrote:

Toufiq wrote:

farew wrote:

That's not a bug with RSForm!Pro. In all other templates the component works perfect.
This happend only in "doctor" template.


Hi, Thanks for your reply. Please check make default joomla template & let me know. Thanks


I've already checked that, see my other answer (RSJoomla Feedback).


Hi, Thanks for your reply with pm. Could you send me administrator info via pm. Thanks
  1. more than a month ago
  2. Doctor
  3. # 6


There are no replies made for this post yet.
Be one of the first to reply to this post!


This forum is archived

This forum has been archived. Please use JoomShaper official support system.