1. Edumatics
  2. Friday, 30 November 2012
Hello,

I am building a multilingual website with Travel Template, till now English language is nearly finished, I installed SH404SEF component for customizing URLs, but something strange happened, English language is my default page(my site is http://www.szswll.com ), when I was in Chinese Language pages, if I click the home menu item of Chinese Language( "首页" in Chinese), normally it should redirect to http://www.szswill.com/cn, but it redirect to the default homepage http://www.szswill.com .

While if I disable SH404SEF, it works correctly. I sourced from internet and some said it might because that the menu module do not work with SH404SEF, has anybody faced similar problems? Any solutions on this problem please?

Thanks.
Responses (8)
No response about this topic?

I have the same problem with another site using Gantry Framework and RokNavMenu module, but finally I found the solution from their forum, they give enthusiastic and timely responses to every questions of their member.

You guys really did bad support, you are so cool and negative to your member's questions. I souced many documentations from many forums, no commercial template or extension developer as cold and irresponsible like you. Many tickets posted in your forum were not well solved and finnally come to nothing, or you just disregard these questions. It is really frustrated.
  1. more than a month ago
  2. Edumatics
  3. # 1
Hi, can I have your admin access? Also, apologize for the delay as we had weekend.
  1. more than a month ago
  2. Edumatics
  3. # 2
thanks for your attention.

How do I send you the admin details ? May I have your email please?
  1. more than a month ago
  2. Edumatics
  3. # 3
The same problem of my another website has been solved already, but you are using different framework and menu module, I can not find similar posts from your forums and have no idea how to do.

I find some posts about the same problems but using Gavick Templates and RocketTheme templates, you can check the links below to get some clues:
http://www.gavick.com/forums/mystore/problems-with-sh404sef-14089.html
http://www.icetheme.com/Forums/111/43064-home-link-always-redirects-to-default-language?limitstart=0
http://www.rockettheme.com/forum/index.php?f=256&t=156958&rb_v=viewtopic

I think there must be something to do with the menu module as the above posts did, hope you can help.

Thanks.
  1. more than a month ago
  2. Edumatics
  3. # 4
Ok, try this one.
Open the class.menu.php from plugins/system/helix/core/ folder and goto line 191
Add this code

$item->url = str_replace(array($item->route.'/', $item->route), '', JRoute::_( $item->url ));

instead of

$item->url = JURI::base();

Now purge url from sh404sef and see if it works or not.
Thanks
  1. more than a month ago
  2. Edumatics
  3. # 5
Thanks a lot, it works now.

So can I update the latest Helix Framework in the future if new versions released?
  1. more than a month ago
  2. Edumatics
  3. # 6
We will add this option from our next version. Thanks.
  1. more than a month ago
  2. Edumatics
  3. # 7
How to change the (off) to the entrance to the site xxx.pl was not redirect to the xxx.pl/en
Currently template varsita redirects to the default interface language for example. / En
  1. more than a month ago
  2. Edumatics
  3. # 8


There are no replies made for this post yet.
Be one of the first to reply to this post!


This forum is archived

This forum has been archived. Please use JoomShaper official support system.