1. Glamour
  2. Tuesday, 21 April 2015
I have SSL activated and when i connect to my site with Chrome it shows this message: "This page is trying to load scripts from unauthenticated sources", how can i solve this problem?
Accepted Answer
Yes i've fixed the problem changing the url in helix framework.
Before url was "http://fonts.googleapis.com" and i've changed it with "//fonts.googleapis.com".
Thanks for your support!
  1. more than a month ago
  2. Glamour
  3. # Permalink
Responses (8)
[UPDATE] The problem is relative to Google font link:
Mixed Content: The page at 'https://www.ele-ven.it/' was loaded over HTTPS, but requested an insecure stylesheet 'http://fonts.googleapis.com/css?family=Maven+Pro:400,500,700,900'. This request has been blocked; the content must be served over HTTPS.
Mixed Content: The page at 'https://www.ele-ven.it/' was loaded over HTTPS, but requested an insecure stylesheet 'http://fonts.googleapis.com/css?family=Nixie+One'. This request has been blocked; the content must be served over HTTPS.


Where can i edit this links with https instead of http?
  1. more than a month ago
  2. Glamour
  3. # 1
Hello Davide,

Your request is outside of the scope of our support. Please contact your SSL certificate provider to consult them on the certificate configuration on your site.

Regards,

Alex
  1. more than a month ago
  2. Glamour
  3. # 2
Instead my request is your scope of support. In fact google fonts are loaded by helix framework in "plugins/system/helix/core/helix.php". I'd just want to know how i can request https connection from google fonts.
  1. more than a month ago
  2. Glamour
  3. # 3
Hi Davide,

Your site https://www.ele-ven.it/ displays fairly cleanly on my Chrome, please have a look at my screenshot attached below. I assume, you are seeing those pesky errors due to your Chrome browser settings.

Regards,

Alex
Attachments (1)
  1. more than a month ago
  2. Glamour
  3. # 4
Hi Davide,

Great to hear you worked it out. Would you mind sharing with me in which file you make your URL change please?

Regards,

Alex
  1. more than a month ago
  2. Glamour
  3. # 5
Alex Smirnov wrote:

Hi Davide,

Great to hear you worked it out. Would you mind sharing with me in which file you make your URL change please?

Regards,

Alex

The file is located in: "/plugins/system/helix/core/helix.php" and the line code is:
addStyleSheet("//fonts.googleapis.com/css?family=" . $name);
  1. more than a month ago
  2. Glamour
  3. # 6
@ Davide Casillo,

Thank you very much. All the best.

Regards,

Alex
  1. more than a month ago
  2. Glamour
  3. # 7


There are no replies made for this post yet.
Be one of the first to reply to this post!


This forum is archived

This forum has been archived. Please use JoomShaper official support system.