1. Vicshaper
  2. Finance
  3. Monday, 21 May 2018
Hello! Can you help us? We put this code in our custom CSS, but the anchor text link doesn't show white. What is the problem? We are using Finance Template.

This is the CSS Code:
buy-tickets-button {
font-size: large;
font-family: 'Open Sans';
color: #FFFFFF;
font-style: bold;
line-height: normal;
font-weight: 900;
background-color: #0f5499;
background-position: center center;
vertical-align: middle;
text-align: center;
padding-top: 10px;
padding-bottom: 10px;
width: 300px;
height: 50px;
float: none;
clear: none;
display: block;
margin-left: auto;
margin-right: auto;
border-style: double;
border-color: #eaf1fb;
}

a.buy-tickets-button:link { color:#FFFFFF; }

Many thanks
Accepted Answer
Accepted Answer Pending Moderation
thanks for HTML code.
Use

.buy-tickets-button a,
.buy-tickets-button a:link { color:#fff !important; }


and where you added you CSS code?
Attachments (2)
  1. more than a month ago
  2. Finance
  3. # Permalink
Responses (4)
Accepted Answer Pending Moderation
Hi,
is there a dot "." before buy-tickets-button {....}
if not, please add it.

Try also


a.buy-tickets-button { color:#fff !important; }
  1. more than a month ago
  2. Finance
  3. # 1
Accepted Answer Pending Moderation
HI and thanks for your answer

This is all the css instruction in the custom.css

.buy-tickets-button {
font-size: large;
font-family: 'Open Sans';
color: #FFFFFF;
font-style: bold;
line-height: normal;
font-weight: 900;
background-color: #0f5499;
background-position: center center;
vertical-align: middle;
text-align: center;
padding-top: 10px;
padding-bottom: 10px;
width: 300px;
height: 50px;
float: none;
clear: none;
display: block;
margin-left: auto;
margin-right: auto;
border-style: double;
border-color: #eaf1fb;
}

a.buy-tickets-button { color:#fff !important; }


and how I recall it with the specific class:

<div class="buy-tickets-button"><a href="https://www.mysite.com" target="_blank" rel="nofollow noopener">THIS TEXT SHOULD BE WHITE</a></div>

I am sorry but it is still no working and it looks like there is no reason why!

Thanks again for your support Paul
  1. more than a month ago
  2. Finance
  3. # 2
Accepted Answer Pending Moderation
Many Thanks for help us! Now every thing is working. Thank you
  1. more than a month ago
  2. Finance
  3. # 3


There are no replies made for this post yet.
Be one of the first to reply to this post!


This forum is archived

This forum has been archived. Please use JoomShaper official support system.