1. broccolihead
  2. Finance
  3. Saturday, 06 January 2018
Hi!
I just installed Joomshaper Finance in an XAMPP environment and received this message. I've not changed any part of the installation. What has gone wrong? Thanks.


Warning: count(): Parameter must be an array or an object that implements Countable in C:\xampp\htdocs\Lions2018\plugins\system\helix3\core\classes\menu.php on line 258
Attachments (1)
Responses (3)
Accepted Answer Pending Moderation
Hi,
to be honest I have no idea.
On normal hosting (no localhost) with PHP 5.6 or 7.0.25 I do not see any warning message.
Hopefully it's only warning, not real bug.
---
Share your localhost basic PHP settings.
  1. more than a month ago
  2. Finance
  3. # 1
Accepted Answer Pending Moderation
Thanks for the reply Paul. My settings are below. The warning appears on the front end, so no good at all! But I see now it is also trashing Extensions>>Templates>>Styles>>shaper_finance - Default>>Layout. (See attachment)

Database Version 5.5.5-10.1.29-MariaDB
Database Collation utf8_general_ci
Database Connection Collation utf8mb4_general_ci
PHP Version 7.2.0
Web Server Apache/2.4.29 (Win32) OpenSSL/1.1.0g PHP/7.2.0
WebServer to PHP If apache2handler
Joomla! Version Joomla! 3.8.3 Stable [ Amani ] 12-December-2017 15:00 GMT
Joomla! Platform Ver Joomla Platform 13.1.0 Stable [ Curiosity ] 24-Apr-2013 00:00 GMT
User Agent Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.132 Safari/537.36
Attachments (1)
  1. more than a month ago
  2. Finance
  3. # 2
Accepted Answer Pending Moderation
PHP Version 7.2.0
is not supported yet.


use lower version.
  1. more than a month ago
  2. Finance
  3. # 3


There are no replies made for this post yet.
Be one of the first to reply to this post!


This forum is archived

This forum has been archived. Please use JoomShaper official support system.