1. SP Page Builder 3.x
  2. Friday, 03 August 2018
I have SP Page Builder installed on a site. It is working fine EXCEPT I have 1 page where the front end edit button will not display.

The button is working as expected and multiple other pages so the issue does appear to be isolated to this one page. It has worked before on this page.

I have checked the page permissions and they do allow for super-user editing. I have also tried duplicating the page and the same behavior occurs on the duplicate.

Any suggestions.
Responses (3)
Hi,
It may be a JavaScript conflict ?
Make some basics tests:

1) Make clone of that page (Save as Copy) and publish on different menu item, where are not any other modules published (in bottom, left, right etc.) - Check
If will not help...
2) On that clone page, delete all Modules Addons. Check.

.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 1
Thanks for the suggestion Paul. - I got the edit button back. I have a couple custom page builder modules on that page, and I guess something has changed in an update - they are throwing an error because the address fields are blank ..... guess I need to look at the code again.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 2
in some cases (personally) I suggest to use HD-anycode module for all custom code (JS etc.)
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 3


There are no replies made for this post yet.
Be one of the first to reply to this post!


This forum is archived

This forum has been archived. Please use JoomShaper official support system.