1. NewsKit
  2. Wednesday, 05 July 2017
Doing some work with the new NewsKit template - the basic article display contains a section of links/adds/blog posts. (See image below)

How does this get turned off? It is part of the default.php code in the article override.

Also,

The articles are all ignoring the LEFT module position (I have a left menu set on some menu items that will not appear) - why is this happening?

Thanks.
Attachments (1)
Accepted Answer
Hi,

Thanks for your reply. Please remove the css code.


.view-article #sp-left, .view-article #sp-right {
display: none;
}
.view-article #sp-main-body .col-md-9 {
width: 100%;
}


-Thanks
  1. more than a month ago
  2. NewsKit
  3. # Permalink
Responses (16)
Hi,

Thanks for your query. Please check the screenshot.

http://prntscr.com/frsgpv

-Thanks
  1. more than a month ago
  2. NewsKit
  3. # 1
Yes - Position of Left (and Right also) - Same Issue.

When in an article, BOTH the left and right positions are given a column (In this case col-sm-3) in the grid, but the modules do not display. The right column is the Popular articles from the new template itself.

The first screen shot is the Blog view with both L/R modules displaying, the second shot is a selected article with the inspector showing that there is a 3/6/3 grid - html is in the page, no display

I have tested this in safari and chrome, so it does not appear to be a browser issue.
Attachments (2)
  1. more than a month ago
  2. NewsKit
  3. # 2
Hi,

Thanks for your reply. Please check the screenshot for change layout of the article.

http://prntscr.com/fs854o

-Thanks
  1. more than a month ago
  2. NewsKit
  3. # 3
Hi Toufiq,

I am having the same problem getting the RIGHT and LEFT positions to display in the article view. I have several items published to the RIGHT position and it only shows in category view/blog layout...but it disappears when you click on any of the individual articles. It seems like something in the article-view (when clicking on the article from the blog) is blocking the RIGHT and LEFT module positions.

I've attached 2 screenshots.

Thanks for help!
Attachments (2)
  1. more than a month ago
  2. NewsKit
  3. # 4
Definitely is an issue in the templates files - not a user error.

Hopefully there will be a fix - or at least confirmation of an error.
  1. more than a month ago
  2. NewsKit
  3. # 5
Hi,

Please share your site url. Let me check the issue.

-Thanks
  1. more than a month ago
  2. NewsKit
  3. # 6
I found what lines in the code are controlling this:

template.css Lines 3849-3852:
.view-article #sp-left,
.view-article #sp-right {
display: none;
}

But, when I commented out these lines, modules published in the RIGHT position shifted below the article content instead of appearing next to it (as shown in the attached screenshot).

Would love to get a fix for this so we can properly display modules in the LEFT and RIGHT positions when in article-view.
Attachments (1)
  1. more than a month ago
  2. NewsKit
  3. # 8
Thanks, Toufiq. That worked for me!
  1. more than a month ago
  2. NewsKit
  3. # 9
Thanks, Toufiq. That worked for me!


Hi, Thanks for your reply & you are most welcome. Thanks
  1. more than a month ago
  2. NewsKit
  3. # 10
I am having this exact same problem I thought I was crazy at first until I saw this. What ended up being the fix?
  1. more than a month ago
  2. NewsKit
  3. # 11
Hey Brian... scroll up in this thread to the top answer. Toufiq showed which code lines to remove in the template.css file.
  1. more than a month ago
  2. NewsKit
  3. # 12
Hey Brian... scroll up in this thread to the top answer. Toufiq showed which code lines to remove in the template.css file.


Hi, Thanks for your instruction :)
  1. more than a month ago
  2. NewsKit
  3. # 13
Hey Brian... scroll up in this thread to the top answer. Toufiq showed which code lines to remove in the template.css file.


Hi, Thanks for your instruction :)


Ya tried that, and oddly nothing happened. Ill try something else. Thanks
  1. more than a month ago
  2. NewsKit
  3. # 14
Hey Brian... scroll up in this thread to the top answer. Toufiq showed which code lines to remove in the template.css file.


Hi, Thanks for your instruction :)


Ya tried that, and oddly nothing happened. Ill try something else. Thanks


Hi, Please share your site exact page url. Thanks
  1. more than a month ago
  2. NewsKit
  3. # 15


There are no replies made for this post yet.
Be one of the first to reply to this post!


This forum is archived

This forum has been archived. Please use JoomShaper official support system.