1. Shari Chambers
  2. SP Page Builder 3.x
  3. Wednesday, 26 February 2020
Hello
I have my site live - blueherontours.ca
If I compress javascript files in the template - I get a "page is not mobile-friendly" when testing with google. I can see the menu is not functioning correctly.
If I turn javascript Compress off, it is mobile-friendly, however - it is seeing the desktop version bh-1.jpg (which is playing a video) and not the mobile version bh-2.jpg (I added a file so you can see the mobile version on responsive layout)
As you know, google tests are very important, how can I make this work properly on google mobile tests?
Attachments (2)
Accepted Answer
Accepted Answer Pending Moderation
robots.txt is from Joomla, not from us.
---
Beside JCH_Otimizer can add extra speed rules for .htaccess - use it.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # Permalink
Responses (6)
Accepted Answer Pending Moderation
Hi,
I repeat this many many times here.
If you have problems with Template CSS/JS optimizer feature, do not use it.
And install JCH_Optimizer or a similar plugin, they have more advanced features, more smart & flexible.

Most users here which listen my advice are now happy, with Google score between 85-98 points.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 1
Accepted Answer Pending Moderation
Thank you for your message. If I turn all optimizing off. I still have google mobile showing the video file even though I have the video disabled for mobile. Is JCH_Optimizer going to fix that?
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 2
Accepted Answer Pending Moderation
JCH_Optimzer is not for fixing issues, it's a tool to compress JS and CSS files etc.

Just check.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 3
Accepted Answer Pending Moderation
JCH_Optimzer is not for fixing issues, it's a tool to compress JS and CSS files etc.

Just check.
Right, I have an issue
If you look at the attachments , where I have a section that has mobile and tablet hidden, in Google mobile-friendly test (just run it on blueherontours.ca) it is seeing the hidden section - it is showing a video I have playing in the background of the section. If you look at the other attachment - this is what should be showing on Google mobile friendly test.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 4
Accepted Answer Pending Moderation
OK, I am editing my robots file, this was the issue I think Sorry!

Thank you
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 5


There are no replies made for this post yet.
Be one of the first to reply to this post!


This forum is archived

This forum has been archived. Please use JoomShaper official support system.