1. SP Simple Portfolio
  2. Tuesday, 28 May 2019
I'm using the Simple Portfolio module at https://ccplus.3catsdigital.com, and have a question. How do I get the image (best) or the header (if needed) to link to an article? I tried to use the URL field in the component but it just sets it to a link to the current page.
Is this possible?
Responses (5)
Hi,
Thanks for your query. I think you are not using the latest version of the sp simple portfolio and check if the issue exists in the default protostar template.
You can check this link https://www.joomshaper.com/forums/how-can-i-link-to-a-page-instead-of-items-in-sp-portfolio#reply-188447

-Best Regards
  1. more than a month ago
  2. SP Simple Portfolio
  3. # 1
I'm using version 1.7, which is listed as the latest version in the downloads section.

FYI - I'm attempting to reproduce the "Our Services" section on the home page of this link: http://purify.foobla.com/index.php. The section has the four images which have a mouseover action. Any way I can do this with this extension?
  1. more than a month ago
  2. SP Simple Portfolio
  3. # 2
Hi,
I think your template may have some override and that's why those buttons are not showing. Please select protostar as your default template and check if the two button appear there or not. You can check this screencast https://files.fm/u/ew8wp22a

-Thanks
  1. more than a month ago
  2. SP Simple Portfolio
  3. # 3
So I went through and found the css overrides in the template, and removed them. The module now works as expected, although I need to go back and add back some of the formatting so it's consistent throughout the site.

One thing I did notice, though - the VIEW button always takes me to the portfolio item, instead of whatever URL is specified in the component. Digging through the code, I found in the component model file items.php the following line 135:


$item->url = JRoute::_('index.php?option=com_spsimpleportfolio&view=item&id='. $item->id . ':' . $item->alias . $itemId);


which would seem to always go to the component page, instead of whatever was put into the URL field. In other words, I can't specify a specific page in the website to go to.

Also, I would like to use the text from the component (the description field) as text in the overlay, like it did with the original template listed above here https://www.joomshaper.com/forums/links-in-simple-portfolio#reply-198211.

I know a way to fix it, but I don't want to do that in case it gets overridden in a future version. Any ideas, other than disabling the update site?
  1. more than a month ago
  2. SP Simple Portfolio
  3. # 4
Hi,
Thanks for your reply. Yes the view button is designed to view the details about that portfolio item. It won't jump you to the url specified in the url. There is no button in frontend to work with the url field and it's already in our todo list( which is quite long ).
We'll fix this in the next update and till then you can use your own customization. And you just need to take a backup every time you update your component to not lose your customizations.

-Best Regards
  1. more than a month ago
  2. SP Simple Portfolio
  3. # 5


There are no replies made for this post yet.
Be one of the first to reply to this post!


This forum is archived

This forum has been archived. Please use JoomShaper official support system.