1. News Show SP1 (not supported)
  2. Monday, 11 November 2013
Dear Sir

Am using Joomla 2.5.16 with K2 version 2.6.7 - My issue is that when am deleting an image of an item in k2 and replacing this image with a new one. Even after clearing the cache and purging expired cache, the thumbnail of the old image continues to show up but inside the item i have the new image showing.

The old image thumbnail is appearing only on the homepage, any idea how i can resolve this issue please?

My website URL is : http://www.defimedia.info

You will see at the top of the page there is a module Live News using News Show SP1 and items being feeded to this module can be found at this link: http://www.defimedia.info/live-news.html

You will notice that the items images on this page are not the same as in the Live News module.

I have even try to upgrade to versio News Show SP2 but the problem still persists.
Responses (13)
I can see that both images are same.
  1. more than a month ago
  2. News Show SP1 (not supported)
  3. # 1
Dear Sir

Let me provide you with some screenshot to clear the matter.

in fact first time i upload an image in an item it appears correctly, but if i want to modify an image and re upload another one the old image continues to appear, see attached file

You will see in the picture named homepage the article appears with an old image whereas in the picture named category the good new image appears correctly inside the category

This happen even after disabling caching for News show sp1 and clearing joomla cache and pruging cache.
Attachments (2)
  1. more than a month ago
  2. News Show SP1 (not supported)
  3. # 2
PM your admin access.
  1. more than a month ago
  2. News Show SP1 (not supported)
  3. # 3
Just PM you my admin access
  1. more than a month ago
  2. News Show SP1 (not supported)
  3. # 4
Dear Kowshar

Have you been able to look into the matter please?
  1. more than a month ago
  2. News Show SP1 (not supported)
  3. # 5
Make your cache directory writable.
Also, I have disabled cache because images are holding by joomla caching thats why you are unable to see changes.
  1. more than a month ago
  2. News Show SP1 (not supported)
  3. # 6
Make your cache directory writable.
Also, I have disabled cache because images are holding by joomla caching thats why you are unable to see changes.


which cache is it?
the one for k2 which is located at media/k2/cache?
or the joomla cache folder?
  1. more than a month ago
  2. News Show SP1 (not supported)
  3. # 7
The joomla cache folder is already writable with permission 755 but still i changed it to 775, i can't disable cache because my site is a high traffic site i can't afford this.
  1. more than a month ago
  2. News Show SP1 (not supported)
  3. # 8
So, how can you expect that image will change automatically when the cache is enabled? Btw, why you are changing images manually?
  1. more than a month ago
  2. News Show SP1 (not supported)
  3. # 9
Before it was working correctly, once i change an image and clear/purge the cache from admin panel it changes the image on the website.

Am changing images manually, because sometimes i add sound or a clip in my articles, and to notify this to viewers i modifiy the image to add a sound logo to the image.

And also what if i upload an image by mistake won't i be able to change this image?
Clean cache from Site -> Maintenance -> clear cache on your Joomla admin area.
I think i found the source of the issue, its with the module News show SP1, i explain:

Lets take this articles as example: http://www.defimedia.info/live-news/item/42069-exportation-de-ferraille-les-conteneurs-en-provenance-de-maurice-contenait-des-pierres.html

see the big image URL: http://www.defimedia.info/media/k2/items/cache/9b7ee3d0350be56446d52e7073839055_XL.jpg

Now on the homepage the thumbnail for this article is this: http://www.defimedia.info/media/k2/items/cache/9b7ee3d0350be56446d52e7073839055_XL_thumb100.jpg

which is created by the module News show SP1

Now see this URL: http://www.defimedia.info/media/k2/items/cache/9b7ee3d0350be56446d52e7073839055_M.jpg

meaning k2 is being able to replace the image and creating the required thumbnail whereas the News Show SP1 module cant overwrite the thumbnail it has previously created with the new image thumbnail.

How do i fix this please?
Note: Right now please disable joomla cache and when development is done then enable cache.
There is no alternate way to solve the issue.


There are no replies made for this post yet.
Be one of the first to reply to this post!


This forum is archived

This forum has been archived. Please use JoomShaper official support system.