1. Helix3
  2. Tuesday, 23 February 2016
Hi,
The issue was already raised a few months ago, but without answer by JoomShaper :
https://www.joomshaper.com/forums/tabs-disappear-in-frontend

I do confirm the issue.
Moreover, it does not only concerns Helix v3 TEMPLATE : I have just tested with other templates base on Helix v3 FRAMEWORK... and the same issue occurs !

It is very annoying : front-end editing does not work correctly for any Type of user (Publisher, Manager, ...), except Super User.

Txs Joomshaper for looking at this and
- provide an update of the Framework
- but also post here to tell what the fix is (without waiting for publishing the update, unless it is immediate)

I have a Developer licence.
This is not just a "nice to have", it is a must for Helix framework to allow front-end editing :-)
Accepted Answer
Marc Dechèvre wrote:

Hi again Toufiq,

Based on your suggestion, I have investigated further.
I think I have found the WORKAROUND :
In Module > Parameters > Permissions > (select the Group you wish ) > Front-end Editing > set to Allowed

See screenshot here : http://screenpresso.com/=p6T7e

But obviously, this is just a WORKAROUND, as the template should allow front-end article editing WITHOUT having to play with Module Permission.
Unless I am mistaken ?

Txs for the follow-up :-)

Marc

http://screenpresso.com/=p6T7e


Dear, Thanks for your reply. Your opinion is right. By the way we will fix it as soon as possible. Thanks
  1. more than a month ago
  2. Helix3
  3. # Permalink
Responses (6)
Dear,

Thanks for your query. We are really sorry for late. Please follow the below instructions.

1. Login your administrator panel
2. System > Global configuration > site tab
3. Check screenshot

-Thanks
Attachments (1)
  1. more than a month ago
  2. Helix3
  3. # 1
OK, so you mean "mouse-over edit icon" should be set to "Module" ?
Mmmh, I have just tried with two sites :
- downloadable Demo of Helix v3 : does not work
- live site based on Template Cuisine : does not work

Can you help further ?
Txs,

Marc
  1. more than a month ago
  2. Helix3
  3. # 2
Hi again Toufiq,

Based on your suggestion, I have investigated further.
I think I have found the WORKAROUND :
In Module > Parameters > Permissions > (select the Group you wish ) > Front-end Editing > set to Allowed

See screenshot here : http://screenpresso.com/=p6T7e

But obviously, this is just a WORKAROUND, as the template should allow front-end article editing WITHOUT having to play with Module Permission.
Unless I am mistaken ?

Txs for the follow-up :-)

Marc

http://screenpresso.com/=p6T7e
  1. more than a month ago
  2. Helix3
  3. # 3
Txs Toufiq :-)
In the meantime I have even further tested :
for the current Workaround, actually both actions have to be taken, namely *your* screenshot (setting on "module" or on "modules & menus" in fact) and *my* screenshot
So the information is complete :-)
Looking forward to the new version of Helix ;-)
  1. more than a month ago
  2. Helix3
  3. # 4
Marc Dechèvre wrote:

Txs Toufiq :-)
In the meantime I have even further tested :
for the current Workaround, actually both actions have to be taken, namely *your* screenshot (setting on "module" or on "modules & menus" in fact) and *my* screenshot
So the information is complete :-)
Looking forward to the new version of Helix ;-)


We will fix it next update version of helix3. Thanks
  1. more than a month ago
  2. Helix3
  3. # 5


There are no replies made for this post yet.
Be one of the first to reply to this post!


This forum is archived

This forum has been archived. Please use JoomShaper official support system.