1. Simon Logan
  2. SP Page Builder 3.x
  3. Monday, 16 July 2018
In relation to the latest release (https://www.joomshaper.com/blog/sp-page-builder-gets-a-speed-boost-smart-search-enhancement), as mentioned in the comments on this blog post, we are unable to follow the steps to re-install the Article integration plugin since the Integrations page seems to be blank.
Accepted Answer
Accepted Answer Pending Moderation
Solved it...at least for me. (PSPB 3.2.6 missing integrations)

I had already changed my php version to 7.2 (7.1, 7.0, 5.6) and also tried setting allow_url_fopen = On (to name a few things). None of them worked.

Then I went to my WHM panel>Multi PHP Manager and turned on PHP-FPM / php 7.2 and it works. Just dumb luck. This might help someone.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # Permalink
Responses (19)
Accepted Answer Pending Moderation
Hi,
Hmm, that's weird I installed 3.2.5 about 5x today, and all of them still have Integration section.
---
Make a test.
Install older version 3.2.4 - enable what you want.
Then install 3.2.5 again and check.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 1
Accepted Answer Pending Moderation
Rolled back it's still missing on that version too so the issue was obviously there before we've just not noticed it since have had no need to look at that page.

The plugin still seems to work it's just not appearing on that page.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 2
Accepted Answer Pending Moderation
In that case it must be php settings issue,
please compare your settings with suggested (sppb 3 manual)
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 3
Accepted Answer Pending Moderation
I have the same issue too. The only PHP setting the sppb 3 manual indicates is allow_url_fopen = ON, which is set on in my environment. Further, SSPB pro came with template purchase. I seem to be unable to download any pro version separately to roll back and reinstall.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 4
Accepted Answer Pending Moderation
@jjdesch - You have " Business " subscription without access to SPPB Pro download section.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 5
Accepted Answer Pending Moderation
Understood - I can use it within my template when installed as a quick start, but I cannot download it separately, so how am I to troubleshoot this?
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 6
Accepted Answer Pending Moderation
@jjdesch -- please send me Private Message (button is hidden inside my profile, click on my avatar) with access to Joomla , so I will be able to check
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 7
Accepted Answer Pending Moderation
Had the same problem. Changed to PHP 7.0. reinstalled SPPB and it works now.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 8
Accepted Answer Pending Moderation
Had the same problem. Changed to PHP 7.0. reinstalled SPPB and it works now.


Yeah that was my suspicion too - so looks like being on PHP 5.6 is the issue?
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 9
Accepted Answer Pending Moderation
I suppose so. I tried that and it worked. Good enough for me. :D
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 10
Accepted Answer Pending Moderation
Had the same problem. Changed to PHP 7.0. reinstalled SPPB and it works now.
What version did you change from? My environment is on 7.1.1 and I am still having this issue
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 11
Accepted Answer Pending Moderation
For temporary time switch to PHP 7.0 set all you need
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 12
Accepted Answer Pending Moderation
Had the same problem. Changed to PHP 7.0. reinstalled SPPB and it works now.
What version did you change from? My environment is on 7.1.1 and I am still having this issue


Mine was 5.6
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 13
Accepted Answer Pending Moderation
PHP 5.6 is almost not supported.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 14
Accepted Answer Pending Moderation
thanks a lot, added into manual > FAQ
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 15
Accepted Answer Pending Moderation
Hello. I have SPB Pro 3.2.8, J 3.8.11, PHP 7.0 but integration list is empty. Is there a way to enable Joomla articles integration cia PHPMyAdmin or by changing some setings in files?
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 16
Accepted Answer Pending Moderation
As I know not really.
You have to try settings from SPPB 3 Manual > FAQ > Blank Integration page
----
Alternative way, install on other hosting set there, make backup and recover on your hosting.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 17
Accepted Answer Pending Moderation
Solved it...at least for me. (PSPB 3.2.6 missing integrations)

I had already changed my php version to 7.2 (7.1, 7.0, 5.6) and also tried setting allow_url_fopen = On (to name a few things). None of them worked.

Then I went to my WHM panel>Multi PHP Manager and turned on PHP-FPM / php 7.2 and it works. Just dumb luck. This might help someone.


Thanks, I just did the same on my WHM and it instantly fixed the problem for me. Thanks.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 18


There are no replies made for this post yet.
Be one of the first to reply to this post!


This forum is archived

This forum has been archived. Please use JoomShaper official support system.