1. Salon
  2. Friday, 08 November 2019
So i have disabled 1 of the two menus and put the logo to the left side, like a more standard website.

However, I cannot change the font size of the menu.

Also, i do not want it to go to the next row, when the desktop resolution is smaller, I just want the menu to shrink in font size to fit in 1 row no matter the desktop resolution ( I use the offmenu for tablets and smaller devices anyways).
Accepted Answer
Hi,
As you wanted to know problem specifications:
I had to change your grid options of module positions of the header from layout.
And for the offcanvas I had to write media query in custom.css file.
https://prnt.sc/q1hndy
Thanks for being with us.

Best Regards
  1. more than a month ago
  2. Salon
  3. # Permalink
Responses (14)
Hi,
Could you please try this custom css

.sp-megamenu-parent li a{
font-size:12px !important;

}

-Regards
Mehtaz
  1. more than a month ago
  2. Salon
  3. # 1
Yeah that works as far as changing it is concerned, but how do i make it stay in 1 line? Try adjusting the width on the site and u will understand what i mean. Also the off canvas menu doesnt appear for mobiles and tablets.
  1. more than a month ago
  2. Salon
  3. # 2
Hi,
Please use this custom css and delete my previous code

.sp-megamenu-parent {
padding-right: 0px !important;
}

By using this your menu is inline.See the screenshot
http://prntscr.com/pw99z8
-thanks
Mehtaz
  1. more than a month ago
  2. Salon
  3. # 3
Hi,
For your off canvas problem try this
http://prntscr.com/pw9cc8
  1. more than a month ago
  2. Salon
  3. # 4
Hi,
For your off canvas problem try this
http://prntscr.com/pw9cc8


Hello Mehtaz,
I have already enabled that but the off canvas menu is still not visible on any screen size.
These are the settings (it shows 2 menu options for some reason)
Attachments (1)
  1. more than a month ago
  2. Salon
  3. # 5
Hi,
You have two menus because your logo was in the middle. Please Select the main menu
I guess you disabled the menu2.
like the indigo template:
https://prnt.sc/pxemmk
Please make sure you only select Mega Menu not mega menu & offcanvas.And also make sure there is a offcanvas module published in the offcanvas position
-Thanks
  1. more than a month ago
  2. Salon
  3. # 6
I tried everything you suggested. However, I don't see any change (off-canvas still not showing). You have covered the rest of my issues though.
  1. more than a month ago
  2. Salon
  3. # 7
I tried everything you suggested. However, I don't see any change (off-canvas still not showing). You have covered the rest of my issues though.

The column contains a menu (menu1 position) is hidden on all breakpoints except lg. Check the settings of this column in layout builder
  1. more than a month ago
  2. Salon
  3. # 8
I tried everything you suggested. However, I don't see any change (off-canvas still not showing). You have covered the rest of my issues though.

The column contains a menu (menu1 position) is hidden on all breakpoints except lg. Check the settings of this column in layout builder


Hey Pavel,
I thought this would finally make it, but it didn't. That's weird. Thanks for the suggestion though.
  1. more than a month ago
  2. Salon
  3. # 9
Hello,

Seeing as the solution hasn't been found yet, can someone help me by logging in the backend and fixing it?

Thanks in advance.
  1. more than a month ago
  2. Salon
  3. # 10
There is still no solution to the offcanvas issue. I simply cannot see it whatsoever. Can you verify it's not a bug related to the template?
  1. more than a month ago
  2. Salon
  3. # 11
There is still no solution to the offcanvas issue. I simply cannot see it whatsoever. Can you verify it's not a bug related to the template?

Hi,
Can you please send me your super user admin access if possible?
I will try to find out your issue...

Note: Please click on my avatar and find the send message button to send your credentials through PM.
Best Regards
  1. more than a month ago
  2. Salon
  3. # 12
There is still no solution to the offcanvas issue. I simply cannot see it whatsoever. Can you verify it's not a bug related to the template?

Hi,
Can you please send me your super user admin access if possible?
I will try to find out your issue...

Note: Please click on my avatar and find the send message button to send your credentials through PM.
Best Regards


Sent a pm yesterday. Let me know if u got it.
  1. more than a month ago
  2. Salon
  3. # 13


There are no replies made for this post yet.
Be one of the first to reply to this post!


This forum is archived

This forum has been archived. Please use JoomShaper official support system.