1. EduCon
  2. Sunday, 08 October 2017
Hello JoomShaper Team,

I have an issue with unwanted redirects to the login / register page.

Simply, I use a component called Ajax Register to create 2 registration forms; there are two distinct user types on my site, so there are two log in forms.

However, when I try to load this Ajax Register registration form (it is a menu item, alias /jobseeker-register-page), the template redirects to a Joomla log in page instead (a menu item with the alias /log-in-register. It is an automatic redirect away from the registration page I want to use!

So I disabled this login page, and the default Joomla registration page, but still the redirect now goes to '/component/users/?view=login&Itemid=101'

This problem is new with this new template, it didn't happen on my previous template.

How can I disable this automatic redirect? I don't need it and it is causing problems!

Thank you for your support,
Best,
Ben
Accepted Answer
Update: actually, it was a log in module called 'improved ajax login' that had a parameter set to 'disallow login' and this module was disabling registration automatically, it wasn't a developer or me who turned off registration, it was the plugin.

Anyway, I hope this information can help you in the future with other clients!

Best,
Ben


Hi, Thanks for your reply. After rename this override folder, If it doesn't work, then its problem of Joomla.

templates/shaper_educon/html/com_users/
templates/shaper_educon/html/mod_login/

-Thanks
  1. more than a month ago
  2. EduCon
  3. # Permalink
Responses (10)
Hi, Please follow the instruction.

File location

templates/your_template/html/com_users/login/default_login.php


Find out this code
<input type="hidden" name="return" value="<?php echo base64_encode($this->params->get('login_redirect_url', $this->form->getValue('return'))); ?>"/>


Replace with this code
<?php $return = $this->form->getValue('return', '', $this->params->get('login_redirect_url', $this->params->get('login_redirect_menuitem'))); ?>
<input type="hidden" name="return" value="<?php echo base64_encode($return); ?>"/>


-Thanks
  1. more than a month ago
  2. EduCon
  3. # 1
Thank you for your efforts, Toufiq, but I made the new changes you suggested and there is no difference.

My registration page (NOT log in page) is https://www.eslrok.com/jobseeker-register-page -- I type this address and still now I am redirected to a standard Joomla log in page, even though I don't have a menu item for a joomla login page; it redirects me to https://www.eslrok.com/component/users/?view=login&Itemid=101.

I have two specific registration pages that use a component called Ajax Register, which I use because it allows me to set specific user groups and specific page redirects for each group after signup, etc. I don't want to use standard Joomla log in or registration pages.

Therefore I would like to completely disable the redirect; currently, the fix (above) that you suggested still does the redirect -- can't we remove the redirect completely?

Thank you again for your time and effort.
Best,
Ben
  1. more than a month ago
  2. EduCon
  3. # 2
Hi,

Please rename this folder from the below file location and try again.

This two folder is override
templates/shaper_educon/html/com_users/
templates/shaper_educon/html/mod_login/

-Thanks
  1. more than a month ago
  2. EduCon
  3. # 3
Hello Toufiq,

I did the above, but still the template redirects to "/component/users/?view=login&Itemid=101", the problem still exists.

What shall I try now?

Best,
Ben
  1. more than a month ago
  2. EduCon
  3. # 4
Hello Toufiq,

I did the above, but still the template redirects to "/component/users/?view=login&Itemid=101", the problem still exists.

What shall I try now?

Best,
Ben


Hi, Thanks for your reply. I would request to you that, please check login menu and login module. Besides, contact your extension provider. Thanks
  1. more than a month ago
  2. EduCon
  3. # 5
Thank you, Toufiq. What do you mean by check? I don't have any login menu (menu item / page) and I don't have any login module published, I disabled it to see if it fixes the problem -- it didn't.

This problem started when I installed the new template, Educon. Before Educon, I used a ZT Smilax template for 2 years with this same configuration (using the Ajax Register component) and with no problems at all, so I guess it is related to the new template.

But I don't know ... do you have any more suggestions? I will contact the Ajax Register team too, but I am desperate now, so I will try anything else you can suggest!

Thank you again for your efforts and patience, I appreciate it very much.
Best,
Ben
  1. more than a month ago
  2. EduCon
  3. # 6
Toufiq, it's fixed!

Some one had turned off 'allow registration' on the admin backend users --> Options. So of course the system did not allow new registrations. A few different developers have been looking at the site so I don't know who did it, but I turned it on again, to allow, and now it loads ok.

You put in so much effort for me and I appreciate it so much. Thank you and please accept my warmest gratitude.

Best,
Ben
  1. more than a month ago
  2. EduCon
  3. # 7
Update: actually, it was a log in module called 'improved ajax login' that had a parameter set to 'disallow login' and this module was disabling registration automatically, it wasn't a developer or me who turned off registration, it was the plugin.

Anyway, I hope this information can help you in the future with other clients!

Best,
Ben
  1. more than a month ago
  2. EduCon
  3. # 8
Update: actually, it was a log in module called 'improved ajax login' that had a parameter set to 'disallow login' and this module was disabling registration automatically, it wasn't a developer or me who turned off registration, it was the plugin.

Anyway, I hope this information can help you in the future with other clients!

Best,
Ben


Thanks a lot :)
  1. more than a month ago
  2. EduCon
  3. # 9


There are no replies made for this post yet.
Be one of the first to reply to this post!


This forum is archived

This forum has been archived. Please use JoomShaper official support system.