1. Helix3
  2. Sunday, 12 March 2017
Hi, i don't want users to access to sub-menu items from main menu on helix3 but only by clicking links in the pages. So I chose not to show the sub-menu items from main menu but as you can see in the attachments the arrow and the dropdown menu (which is empty) are still showing.
How can I remove the arrow from defoult main menu (there is no module for that).
Than you
Andrea
Attachments (1)
Responses (9)
Hi Andrea,
I think I can help You:

.sp-megamenu-parent > li.sp-has-child > a::after {display:none; }
Attachments (1)
  1. more than a month ago
  2. Helix3
  3. # 1
Thank you Paul, it works for the arrow but the dropdown menu is still showing on mouse over.
Can you please help me again?
Thanks a lot
Andrea
  1. more than a month ago
  2. Helix3
  3. # 2
You want to hide all submenu boxes, right?
---

.sp-dropdown.sp-dropdown-main {display:none;}
  1. more than a month ago
  2. Helix3
  3. # 3
Right. I did what you told me but the dropdown box is still showing as you can see in the attachment.
Sorry for that, any suggestion?
Than you Paul
Attachments (1)
  1. more than a month ago
  2. Helix3
  3. # 4
upss, no problem....
please add also this:


.sp-megamenu-parent .sp-dropdown .sp-dropdown-inner {background: transparent; box-shadow: none;}
  1. more than a month ago
  2. Helix3
  3. # 5
I update your last line and now it works.
Thank you very much for your help.
Andrea
  1. more than a month ago
  2. Helix3
  3. # 6
No problem, welcome.
---For all others - ALL IN ONE ---
.sp-megamenu-parent > li.sp-has-child > a::after,
.sp-dropdown.sp-dropdown-main {display:none; }
.sp-megamenu-parent .sp-dropdown .sp-dropdown-inner {background: transparent; box-shadow: none;}
  1. more than a month ago
  2. Helix3
  3. # 7
It works as well with these lines:
.sp-megamenu-parent > li.sp-has-child > a::after {display:none; }
.sp-megamenu-parent .sp-dropdown .sp-dropdown-inner {background: transparent; box-shadow: none;}
  1. more than a month ago
  2. Helix3
  3. # 8
I'd like to share some of my experiences trying to fix the same issue. I'm on template kidzy.

- I never got the arrow to disappear using this css...
- Removing the menu background worked after also removing the padding on .sp-megamenu-parent .sp-dropdown .sp-dropdown-inner {background: transparent; box-shadow: none;} => therakes sense.

I'm not pretending that I did everything right for sure, nor do I have a good explanation. But after a lot of trial and error what fixed it for me in the end was simply going to 'Helix Menu Options' for the menu item (the one you want to hide) and set 'Show Menu Title' to "NO" - as well as hiding the menu item as usual. This solution was by far the most elegant for my use case. Please enjoy the hours that I lost :)
  1. more than a month ago
  2. Helix3
  3. # 9


There are no replies made for this post yet.
Be one of the first to reply to this post!


This forum is archived

This forum has been archived. Please use JoomShaper official support system.