1. Kidzy
  2. Monday, 15 April 2019
If i place a hidden menu item in the second level of the main menu. When hovering this item, an empty box is shown. Any clue how i could fix this quickly? Please see attached screenshot.
Attachments (1)
Accepted Answer
Thanks, sorry for the delay, I had to miss your PM
1) I got access.
2) Fixed.

I modified the code a little bit


.hidebelow .sp-dropdown.sp-dropdown-main,
.hidebelow div.sp-dropdown.sp-dropdown-sub,
.hidebelow a::after {visibility: hidden; display: none !important;}


I put it inside custom.css - so it's used on whole website

and used class name here
here.png
Attachments (1)
  1. more than a month ago
  2. Kidzy
  3. # Permalink
Responses (11)
Hi,
only by using extra custom.
Please read tips : https://www.joomshaper.com/forums/menu-showing-a-blank-dropdown
  1. more than a month ago
  2. Kidzy
  3. # 1
Thanks for your reply, i followed the instructions and added the css to the custom css code:

.hidebelow div.sp-dropdown.sp-dropdown-sub,
.hidebelow a::after {visibility: hidden; display: none !important;}


Cant figure out where to put the custom class name as the menu is not loaded in a module.
  1. more than a month ago
  2. Kidzy
  3. # 2
It main menu item "News" -- check options, there is field for custom class
  1. more than a month ago
  2. Kidzy
  3. # 3
Thanks, found it, but cant get it working:
added custom css in the template:

.hidebelow div.sp-dropdown.sp-dropdown-sub,
.hidebelow a::after {visibility: hidden; display: none !important;}

and added the classname to the link class field
https://imgur.com/GjXDjZf

tried it with and without dot and space before

Any clue whats wrong?
  1. more than a month ago
  2. Kidzy
  3. # 4
Try from "Helix MegaMenu Options" tab -- there is class field
  1. more than a month ago
  2. Kidzy
  3. # 5
There seems something happening, the empty sub menu is moving a little downwards, but it is still there. See attachment. Any clue what i am doing wrong? For some reason i cant find the css back from the hidebelow when inspecting the element.
Attachments (2)
  1. more than a month ago
  2. Kidzy
  3. # 6
I have to see URL to tell more
  1. more than a month ago
  2. Kidzy
  3. # 7
I send you a PM
  1. more than a month ago
  2. Kidzy
  3. # 8
Thanks, sorry for the delay, I had to miss your PM
1) I got access.
2) Fixed.

I modified the code a little bit


.hidebelow .sp-dropdown.sp-dropdown-main,
.hidebelow div.sp-dropdown.sp-dropdown-sub,
.hidebelow a::after {visibility: hidden; display: none !important;}


I put it inside custom.css - so it's used on whole website

and used class name here
[attachment]here.png[/attachment]


Thanks for your help! got it working now
  1. more than a month ago
  2. Kidzy
  3. # 9
Thanks for posting this - this helped me hide a sub-sub menu from the Spectrum template.
  1. more than a month ago
  2. Kidzy
  3. # 10


There are no replies made for this post yet.
Be one of the first to reply to this post!


This forum is archived

This forum has been archived. Please use JoomShaper official support system.