1. Helix-II
  2. Saturday, 25 January 2020
Any attempt to upgrade PHP to a supported version on my hosting platform fails because of Helix II. When changing PHP to the minimum supported version of 7.2, it throws the following error:

Warning: A non-numeric value encountered in /home/midwem1w/public_html/plugins/system/helix/core/classes/menu.php on line 289

This error is only with the menu. I attach two images of the behavior on 7.0 and 7.2. I would please need help to fix this issue on Line 289.

Here is the line in question: $width += $colw;

I need help to upgrade successfully.
Attachments (2)
Accepted Answer
You can ignore this warning by setting Error Reporting to None. I hope this solves your issue.

Screenshot_127.png

- Best regards
Attachments (1)
  1. more than a month ago
  2. Helix-II
  3. # Permalink
Responses (3)
Thanks, that worked.
  1. more than a month ago
  2. Helix-II
  3. # 1
Thanks, that worked.


You are welcome.

- Best regards
  1. more than a month ago
  2. Helix-II
  3. # 2


There are no replies made for this post yet.
Be one of the first to reply to this post!


This forum is archived

This forum has been archived. Please use JoomShaper official support system.