1. General discussions
  2. Friday, 05 June 2020
Hi, I am starting to experiment with the new Joomla 4 beta. The attempt to install the (relatively recent) Yamas template lead to:

An error has occurred.
0 Call to undefined method Joomla\CMS\Application\AdministratorApplication::isAdmin()

Following that the administrator backend is not operable anymore. Before the install, all was fine. The template was the very first change.

Front end throws the same error.

Any ideas please? Or is it simply too early?

Thanks and regards,

Dan

J4 beta
PHP 7.3
Responses (7)
Github reports an incompatibility of the extension:

[4.0] Error: Call to undefined method Joomla\CMS\Application\AdministratorApplication::isAdmin() #24642

but apparently also an easy fix that Joomshaper may want to implement.

Thanks!
  1. more than a month ago
  2. General discussions
  3. # 1
Hi. I also experimented with this with the same result. Of course this is not yet ready for the J4. But I think it is high time to prepare.

In any case, Helix Ultimate should be used for experiments, but not Helix based templates. Because Helix Ultimate - is something that is updated first. Hopefully the guys will soon release Helix Ultimate 2.
  1. more than a month ago
  2. General discussions
  3. # 2
Thanks Pavel!

Helix Ultimate should be used for experiments.


Has that worked? And how about Page Builder?

I am not vested in any templates. Just playing around with J4. Can also do without Joomshaper for the moment. But I thought it helps the team if there are more eyes. Which raises another question: will there be a forum category or tag specific to J4? Might be helpful in focusing the discussions.

Thanks!

Dan
  1. more than a month ago
  2. General discussions
  3. # 3
Has that worked? And how about Page Builder?

No, I wrote about it above. Page Builder not yet ready for the J4 too. We can only wait for the Joomshaper guys make it compatible with J4.
  1. more than a month ago
  2. General discussions
  3. # 4
Hi, as you noticed J4 is still in the first beta1, so I don't see a reason to create a forum category for this in the next days. We are not the Official Joomla Forum. Before J! stable version is a long way, at least 2-3 months. Before you will get 3.10.

Just playing around with J4.

Beta versions are for this purpose only.

Yes, we planned. This is obvious.
  1. more than a month ago
  2. General discussions
  3. # 5
Hi Paul, no problem!

I don't see a reason to create a forum category


I had just thought that testers could help identify bugs. But they still seem to be so fundamental (my issue goes back to a change from 2016, that has worked even in J3) that you probably have a long list to work on.

"The mention method has been deprecated in October 2016. So at some time old functions need to be removed ;) ... But the good thing is that isClient($identifier) works with all supported versions and in the end a search and replace."

Anyways, happy to wait!

Thanks and regards,

Dan
  1. more than a month ago
  2. General discussions
  3. # 6
For sure, in next months SPPB will get J4 support as well as Helix Ultimate.
  1. more than a month ago
  2. General discussions
  3. # 7


There are no replies made for this post yet.
Be one of the first to reply to this post!


This forum is archived

This forum has been archived. Please use JoomShaper official support system.