1. GGGolf
  2. SP Page Builder 3.x
  3. Thursday, 13 August 2020
We are facing yet another bug with PageBuilder, sometimes the front-end editor tools "Blocks" and "Layouts" both fail. I've found out that this is caused by invalid cache files on disk, the culprit files are in cache/sppagebuilder : sections.json and templates.json which, when the bug occurs, are empty (0 bytes) !

BTW on our installation the Joomla caching is disabled! I would expect PageBuilder not to use any cache in this scenario but it doesn't care... We cannot enable Joomla Caching.

The fix is immediate, delete both files and refresh the front end editor. Instantly the files are re-generated (both total around 3.5MB!) and the editor works!

After a while (I don't know the trigger) those valid files are flushed and empty files are generated AGAIN.

IMO the code should at least detect empty files and consider they do not exist in such case, at least the system would automatically get back working even if there is a bug somewhere causing the empty files...
Responses (1)
Accepted Answer Pending Moderation
Hi there,

Thanks for contacting us. Sorry for the inconvenience. Please capture a screencast video about your issue. Besides, Provide me the Joomla administrator access via PM.

-Thanks
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 1


There are no replies made for this post yet.
Be one of the first to reply to this post!


This forum is archived

This forum has been archived. Please use JoomShaper official support system.