1. Tixon
  2. Sunday, 23 February 2020
HI,

I have uploaded the Quickstart for Tixon to my site and get the error message "Failed to start the session" when I go to the web site to finish the installation. I tired a second site with Moview and get the same response.

http://autoexperience.ca/installation/index.php
http://racecanada.tv/installation/index.php

My PHP is currently 7.2.

I have uploaded quick start packages from other suppliers in the exact same way as I have done this one and they have worked, so there must be something a little different with this one that I am doing wrong.

Any help would be appreciated,
Thanks,
Mike
Accepted Answer
Hi Paul,

Thanks for the quick response, I think I figured out the problem, here is the description.

I tried uploading the template above and got the same thing.

I then uploaded a template quick start package I have used successfully in the past, and got an internal error.

I decided to set the PHP back to 5.6, the setting it was at when I used the other package successfully. All three sites now showed the Joomla Installation screen.

I reset the PHP to 7.0, and the installation screens were still there for your packages, although gone for the older one, which wasn't too surprising.

When I set the PHP up 1 more to 7.1, I got the error messages again, so I would have to say that the 3 packages I have so far uploaded, Knight, Tixon and Moview, need PHP 7.0 at the highest. My current site works properly with 7.0, so all is good for me, but I think we have now solved the problem and I can get to work customizing things tomorrow morning, assuming no more issues!!

Thanks again for the quick response,
Mike
  1. more than a month ago
  2. Tixon
  3. # Permalink
Responses (7)
Hi,
1) for test purpose try:
https://www.joomshaper.com/downloads/template/keynote

2) Are you able to install raw Joomla package, downloaded from joomla.org?
  1. more than a month ago
  2. Tixon
  3. # 1
Mike, from my side, thank you for the checking,
indeed those 3 templates are "old" and their installer may not be ready for PHP 7.1 and above
  1. more than a month ago
  2. Tixon
  3. # 2
Mike, from my side, thank you for the checking,
indeed those 3 templates are "old" and their installer may not be ready for PHP 7.1 and above


Hi Paul,

Unfortunately, a new problem today. I can now get the Joomla installation page to come up, but I can't get past the first page of the installation.

I finish filling out the information on the first page, click next and the Joomla logo spins for a couple of seconds, then the first page comes up again, with all the information I entered still in the fields, and I can't go to the next page.

I have tried it on the 3 different templates I have loaded up so far, and get the same thing on all 3, so I don't think it is just a case of a bad upload, unless all my uploads had the same problem.

I've tried it with 3 different browsers on 2 different computers, one desktop, one lap top, and again the results are the same.

I even tried lowering the PHP down to 5.6 to try it, but still the same outcome.

Any thoughts or advice on what to try would be appreciated.

Thanks,
Mike
  1. more than a month ago
  2. Tixon
  3. # 3
In general, it's not normal, all steps are from Joomla core installer, we only added our demo sql file.
---
Are you able to install raw Joomla 3.9, downloaded from Joomla.org ?
  1. more than a month ago
  2. Tixon
  3. # 4
In general, it's not normal, all steps are from Joomla core installer, we only added our demo sql file.
---
Are you able to install raw Joomla 3.9, downloaded from Joomla.org ?


Hi Paul,

I set my php back down to 5.6 and tried loading one of the old quickstart's that I have successfully done in the past, and it did the exact same thing, so I figured this had to be something on my end, not yours.

After digging around on the internet, I found a suggestion to make a change to the PHP.ini file to make sure that the max_execution_time must equal at least 300.

Thinking this was in the quickstart kit, I searched for the file and couldn't find it, got frustrated and went to bed.

This morning, when I went to set the PHP back to 5.6, I noticed that the PHP.ini file is part of my Control Panel.

After quick search, I found the setting and it was set to 120. I changed it to 300 and now it works fine, at least to the second page!

This is what the section on my Control Panel PHP.ini file looks like:

;;;;;;;;;;;;;;;;;;;
; Resource Limits ;
;;;;;;;;;;;;;;;;;;;

; Maximum execution time of each script, in seconds
; http://php.net/max-execution-time
; Note: This directive is hardcoded to 0 for the CLI SAPI
max_execution_time = 120

This was my original setting, it is now at 300 and, so far, working fine.


So, in short, I have learned that if you get a "Failed To Start The Session" message when you first go to the web site to finish the installation, you likely have a PHP version issue and if you get hung up on the first screen where you can't move to the second screen, you likely have a "max_execution_time" below 300.

I think (hope?) this should now all be sorted out, thanks for the quick responses, it's always appreciated. Especially since all the errors ended up being on my end...

Thanks again,
Mike
  1. more than a month ago
  2. Tixon
  3. # 5
ABout "max_execution_time" I am not surprised, I added info about it in almost any template documentation in "Technical Requirements" section.
  1. more than a month ago
  2. Tixon
  3. # 6


There are no replies made for this post yet.
Be one of the first to reply to this post!


This forum is archived

This forum has been archived. Please use JoomShaper official support system.