1. SP Page Builder 2.x (not supported version)
  2. Thursday, 15 December 2016
Hello

I tried to use the carousel component with page builder Pro 2.3 in Helix3 template
I have a carousel with 3 items.

in autoplay:
1st item shows
2nd is not showing,
3rd item shows
1st item not showing,
etc.

Same with Carousel Pro.

http://jo-test36.mazdaznan.de/de/?option=com_sppagebuilder&view=page&id=7

Thanks for your help.

Best regards
MarcoT
Accepted Answer
Sorry I got your message today, with delay.
---
Please disable module :: improved Ajax Login and check homepage again.
This module use unsupported mootools which cases conflicts and issues.
If you want to use it with our products ask its developer to replace mootools to jquery like any other J! developer.
Responses (36)
Hi,
I think I have a cure:
Here: /templates/shaper_helix3/js/main.js
replace with my file (unzip before) - use FTP tool !
Attachments (1)
I replaced it, but it does NOT work on my site:
http://jo-test36.mazdaznan.de/de/?option=com_sppagebuilder&view=page&id=7
still the same.
:(

EDIT:
After I cleared my own "browser cache" IT WORKS!
:)
Sorry, my fault!

Thanks for the "magic code" in main.js.
See last post!
I used this for an other site still running with old Helix 1.2 and It also works fine!
:)


Best regards
Marco
by the way:
My site is not loading on Firefox, only after I disabled the "preloader" in my template.
Chrome works fine.

Best regards
Marco
it works?
Paul Frankowski wrote:

Hi,
I think I have a cure:
Here: /templates/shaper_helix3/js/main.js
replace with my file (unzip before) - use FTP tool !


it works this method?
Alberto Salazar wrote:

it works?


I don't have access to customer site to check what would happen after switch off that module. User must to do it alone.
--
But In most cases problems are caused by old modules which uses mootools instead of jquery.
sorry, for the late reply.
Yes indeed, after disabling the module :: improved Ajax Login it looks fine.
What a pity. ;-(
Thanks for your help!
I will contact the developer as you suggested!
You are welcome.
Hi

I have the same problem. I do, however, not find the "module :: improved Ajax Login". When searching for "ajax" amongst my extensions, I find 1) Ajax Interface (a component which cannot be disabled) and 2) Helix3 - Ajax, which, when disabled, makes no difference.

The page has one CarouselPro row which runs fine. It is the second CarouselPro row which slips every second image from the display.

Please advise?

Francois Barnard
I tried the regular Carousel in stead of CarouselPro, and the same problem occurs that as well.
Please send me your site URL and Super Admin Access then let me check. Thanks
So this is not resolved. I have the same problem and I just got sp builder last week. Switched from T-3 to Helix because of sp builder advantages.

Lot od other issues too: (i) off canvas does not work on mobile.(i) three columns in one row is responsive the same three in the next row not; (iii) deleted row keeps appearing on mobile.

But I am a Newbie so it could just be my mistakes.Any help would be welcome
SUDHEE
ad 1) off canvas does not work on mobile, because you have to publish menu module in Offcanvas position
ad 2) Make sure that you have the last version of SP PB 2.3.3
ad 3) Clear Joomla and browser cached files.
Please send me your site URL and Super Admin Access then let me check. Thanks


I sent you the details in a private message.

Thank you

Francois
I got that and replied in private message.

Carousel/pro is working with Joomla. If you use any system plugin that contain MooTools, sometimes which can create issue. MooTools is out from Joomla frontend and we are recommended not to use MooTools.

Thanks
Hi Nayem

This same problem recurred now in a different website of mine - see http://sweefdrama.co.za/index.php?option=com_sppagebuilder&;view=page&id=1

(the above link will work if you remove the semi-colon before "view";)

I am using an Artisteer template here, and cannot just replace the template and redo the whole website because SP Pagebuilder does not like MooTools. Kindly find a solution for me to get it working on the existing website?

Regards,

Francois
Hi Francois Barnard,

I will check on weekdays. Thanks
Following this thread because I am having the same problem

https://www.joomshaper.com/forums/carousel-pro-item-2-disappears
Sorry I got your message today, with delay.
---
Please disable module :: improved Ajax Login and check homepage again.
This module use unsupported mootools which cases conflicts and issues.
If you want to use it with our products ask its developer to replace mootools to jquery like any other J! developer.


Hi Paul, I obviously have the same problem / symptoms – but I do not find any module improved Ajax Login. Please advice. Thanks, Julian
The only "Ajax" I find is the "Ajax Interface Component"
Hello

I tried to use the carousel component with page builder Pro 2.3 in Helix3 template
I have a carousel with 3 items.

in autoplay:
1st item shows
2nd is not showing,
3rd item shows
1st item not showing,
etc.

Same with Carousel Pro.

http://jo-test36.mazdaznan.de/de/?option=com_sppagebuilder&view=page&id=7

Thanks for your help.

Best regards
MarcoT




-----> Taking advantage, which page translator are you using?
about "magic" code from main.js, we used :


//fix carousel issue for mootools
var carousel = jQuery('.carousel');
if(carousel){
window.addEvent('domready', function(){
if (typeof jQuery != 'undefined' && typeof MooTools != 'undefined' ) {
Element.implement({
slide: function(how, mode){
return this;
}
});
}
});
}


it must be added in main.js file (at the end) or other if you have different not helix3 template.
Many thanks for the "magic code" in main.js.
I used this for an other site still running with old Helix 1.2 and it also works fine - after I cleared my browser cache!!!
:)

Problem solved. :)
And all works fine also with my module "improved Ajax Login"!

So, that means, that everyone can use Mootools extensions together with Helix 3, also in the future?
Will this "magic code" be included into the next Helix 1.9 update?
-----> Taking advantage, which page translator are you using?


I'm native German. :-)
I have this problem on a site using an Artisteer template. The Artisteer template does not have a main.js, only jquery.js, modules.js, script.js and script.responsice.js

To which one do I add the code?
I have this problem on a site using an Artisteer template. The Artisteer template does not have a main.js, only jquery.js, modules.js, script.js and script.responsice.js

To which one do I add the code?


Send me FTP access of your site. Thanks
I updated to Helix 1.9 and all the problems are back again.
Wasn't this "magic code" included into the Helix 1.9 update?
create a 'custom.js' file under '/js' folder then write that magic code into custom.js file.

Then compress/minify javascript from helix3 dashboad. Thanks
probably it doesn't have, so you have to add again into main.js
create a 'custom.js' file under '/js' folder then write that magic code into custom.js file.

Then compress/minify javascript from helix3 dashboad. Thanks


OK, THANKS!
Will do that!
create a 'custom.js' file under '/js' folder then write that magic code into custom.js file.

Then compress/minify javascript from helix3 dashboad. Thanks


BTW:
Why so 'complicated'? ;-)
It would be much more convenient, if there would be an input field in the Template Tab under:
.../administrator/index.php?option=com_templates&view=style&layout=edit&id=31#attrib-custom_code

What do you think?
Yes. You can. It's an another good option. ;)
Guys, please, so many updates later and the solution is still a manually entered "magic code". Can we not have it fixed from scratch?

You "magic code" fix never worked for me. The Carousel works fine if there is only one instance of it, The second carousel on the same page "knit-one-slip-one" as described above.
From PC it works, but from mobile the problem still remains :(

Hi,
I think I have a cure:
Here: /templates/shaper_helix3/js/main.js
replace with my file (unzip before) - use FTP tool !
refresh browser 2x
---
besides disable all extra modules which use mootools


There are no replies made for this post yet.
Be one of the first to reply to this post!


This forum is archived

This forum has been archived. Please use JoomShaper official support system.