1. Arino
  2. Tuesday, 14 January 2020
Hi,
I have a small problem, on the page where the product is displayed, the first variant does not appear in the dropdown selection. The field is empty. How do I fix this? And one more question ... I cannot translate the word "Description". I installed the required language and tried it with override, but it's not working.

https://imgur.com/WpcE0oV (screenshot)

http://stojanovicbau.de/wels/index.php/de/shop/welsangelsport/rollen/stationaerrollen/shimano-rarenium-ci4 (site)

Best regards
Accepted Answer
Hi there,

Thanks for your PM. Added this CSS code to solve the issue. Now it works fine.


.view-products select {
padding: 0px 0px 0px 5px;
}


-Thanks
  1. more than a month ago
  2. Arino
  3. # Permalink
Responses (10)
Hi there,

Thanks for contacting us. I have checked the URL about of your select box. It works fine.

https://prnt.sc/qo36ty

Description of Language change
language/en-GB/en-GB.tpl_arino.ini
https://prnt.sc/qo3aah

-Thanks
  1. more than a month ago
  2. Arino
  3. # 1
Hi,
yes, everything works but the dropdown field is empty instead of appearing the first of the possible choices or simply appearing "Select", as here ...

http://welsangelsport.ch/welsangelsport_3/index.php/shop/kategorie/rollen/stationaerrollen/shimano-sahara-rd (site)

https://imgur.com/poJYUXm (screenshot)

********************************************************************************************************
Here is the current situation (blank field) ....

http://stojanovicbau.de/wels/index.php/de/shop/welsangelsport/rollen/stationaerrollen/shimano-rarenium-ci4 (site)

https://imgur.com/PiulMjC (screenshot)

With "Description" now everything is ok. Translation succeeded with override and language constant J2STORE_PRODUCT_SORT_DESCRIPTION

but this first question still stands

greeting
  1. more than a month ago
  2. Arino
  3. # 2
Hi there,

Thanks for your reply. But, the select box is not empty found.

https://prnt.sc/qodvrr
https://prnt.sc/qodvxz

-Thanks
  1. more than a month ago
  2. Arino
  3. # 3
Hi,
It's weird. I use Firefox Mozilla and in that browser variants are not visible. I tried the microsoft edge itself which is in win10 and they are not seen.

When I select a variant or model from the dropdown, the price changes, but the model that was selected is not visible in the field. The field remains blank. This is how I see it.

Capture_3_foto.jpg

Capture_4_foto.jpg
Attachments (2)
  1. more than a month ago
  2. Arino
  3. # 4
Hi there,

Thanks for your information. Please add this css code inside the custom.css file.


input[type="text"]:not(.form-control), input[type="email"]:not(.form-control), input[type="url"]:not(.form-control), input[type="date"]:not(.form-control), input[type="password"]:not(.form-control), input[type="search"]:not(.form-control), input[type="tel"]:not(.form-control), input[type="number"]:not(.form-control), select:not(.form-control) {
display: block;
width: 100%;
padding: 0px 0px 0px 5px !imporatnt;
font-size: 1rem;
line-height: 1.25;
color: #495057;
background-color: #fff;
background-image: none;
background-clip: padding-box;
border: 1px solid #e4e4e4;
border-radius: 2px;
transition: border-color ease-in-out 0.15s, box-shadow ease-in-out 0.15s;
}


-Thanks
  1. more than a month ago
  2. Arino
  3. # 5
Hi,
I inserted the code you sent, but nothing has changed. I can give you an administrator pass to see what this is all about.

Thanks
  1. more than a month ago
  2. Arino
  3. # 6
Hi there,

Thanks for your reply. Please provide me the Joomla administrator access via PM.

-Thanks
  1. more than a month ago
  2. Arino
  3. # 7
Yes, that is it. Now it works. :)

Thanks
  1. more than a month ago
  2. Arino
  3. # 8
Yes, that is it. Now it works. :)

Thanks



Hi there, You are most welcome & Thanks
  1. more than a month ago
  2. Arino
  3. # 9


There are no replies made for this post yet.
Be one of the first to reply to this post!


This forum is archived

This forum has been archived. Please use JoomShaper official support system.