1. Joris Stolker
  2. SP Page Builder 3.x
  3. Friday, 23 August 2019
Hi there,

I am custom styling a website with my CSS.
Now i saw that the design is changing in edit mode or not.
So i checked why...

A column has an other class in edit mode.
sppb-column (normal view)
sp-pagebuilder-column (edit view)

https://www.dropbox.com/s/tsb6bli3qa3nctb/Schermafdruk%202019-08-23%2017.19.07.png?dl=0
https://www.dropbox.com/s/1fgmlrpdy07k07l/Schermafdruk%202019-08-23%2017.19.01.png?dl=0

I would think this is a bug.
Ofcourse i will change my css not but it is very unexpected :-D

Thanks!
Accepted Answer
Accepted Answer Pending Moderation
Hi,
Thanks for your query. Actually some of the classes in our editor mode is different from the normal view. That's why we encourage to use the normal view to use your custom css and use only those classes from normal view.

-Best Regards
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # Permalink
Responses (5)
Accepted Answer Pending Moderation
Hi Sifat,

Wel the design edit mode is there to see what you are doing.
Now it is a mess in the edit mode and looks good for customers.
Ofcourse a little difference is no issue, i am used to that. But different classes is not expected and not logical.
If you ask me that is wrong or a bug.
Now that i know it i write to both classes but that double work, and i would like to be faster and not slower ;-)

Wish you a great day!
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 1
Accepted Answer Pending Moderation
Thanks for your generous reply :)

-Best Regards
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 2
Accepted Answer Pending Moderation
Good that you see this as a generous reply :-)
I hope you check this out at your end, maybe that there is a very good explanation for you.
For me as designer and lover of custom css this is not what i could expect.

I am happy with SPpagebuilder, thanks for the great extension!
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 3
Accepted Answer Pending Moderation
Thanks for your response. I've already forwarded this to our development team and that's what i can do for you :)

-Best Regards
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 4


There are no replies made for this post yet.
Be one of the first to reply to this post!


This forum is archived

This forum has been archived. Please use JoomShaper official support system.