1. Helix3
  2. Thursday, 21 May 2015
Hello,

how can I edit the 404 page shown in Helix-3 ?

I am aware of the additional module position 404, but I want to edit/change the entire 404 site, not just display additional modules.

Many thanks!
Torsten
Accepted Answer
Hi,

Thanks for your query. Please following the instruction.

1. Go to the language directory & open the file en-GB.ini file
/language/en-GB/en-GB.ini
2. Find out this code & change the page not found text

JERROR_PAGE_NOT_FOUND="Page not found"


-Thanks
  1. more than a month ago
  2. Helix3
  3. # Permalink
Responses (22)
Hi,

templates\shaper_helix3\error.php

Thanks
Arun
  1. more than a month ago
  2. Helix3
  3. # 1
Hi Arun,
I customize the error.php several times but it is reverting the default page (which came with the template) after sometime (may be 24 hrs)
Is it set dynamically to revert the page?
  1. more than a month ago
  2. Helix3
  3. # 2
How it is reverting?
  1. more than a month ago
  2. Helix3
  3. # 3
Arun Sasi wrote:

How it is reverting?

I have no idea , how is it reverting...
I edited error.css page to add the customized formatting with image but it revert back to the original error page after I checked the next day.
Then I tested it with several times and all the time it was same.
  1. more than a month ago
  2. Helix3
  3. # 4
How you are editing the css? Did you enabled Less complier?
  1. more than a month ago
  2. Helix3
  3. # 5
How can I get id off this 'Page not found' message in English?

Though my site is in turkish and translated JERROR_PAGE_NOT_FOUND the message still appears in english
  1. more than a month ago
  2. Helix3
  3. # 6
Hello everyone

how do I change the page code of the error.php to display a page created in the SP-Builder? I have already tried a lot but always get error messages. Your own page has the ID-130.
Thanks for the help in advance.

Greeting Siegfried
  1. more than a month ago
  2. Helix3
  3. # 7
Hello all,

the solution I am using:

1. create custom 404 page in pagebuilder
2. assign it to a hidden menu, so you are getting an url. I am using a menu called "hidden" which is hidden... in my example the name is 404
3. Edit the file error.php in your template root directory /templates/shaper_xxx/error.php. Just add the following code at the beginning of the file, see example (I used the standard error.php of joomla)

<?php
/**
* @package Joomla.Site
* @subpackage Template.system
*
* @copyright Copyright (C) 2005 - 2017 Open Source Matters, Inc. All rights reserved.
* @license GNU General Public License version 2 or later; see LICENSE.txt
*/

defined('_JEXEC') or die;

/** @var JDocumentError $this */
if (($this->error->getCode()) == '404') {
header('Location: /404');
exit;
}

4. Replace the /404 with the url of your pagebuilder page.

5. save the file.
done.

It will show as every normal content page, with your header and footer.
  1. more than a month ago
  2. Helix3
  3. # 8
Thanks for your help. Has worked great.
  1. more than a month ago
  2. Helix3
  3. # 9
Need help again.
Since the last update of Joomla, Helix and Pagebuilder the script for its own error.php no longer works. I always get an error message. Can someone help me why it no longer works.

Error

Page


----------------------
<?php
/**
* @package Joomla.Site
* @subpackage Template.system
*
* @copyright Copyright (C) 2005 - 2017 Open Source Matters, Inc. All rights reserved.
* @license GNU General Public License version 2 or later; see LICENSE.txt
*/

defined('_JEXEC') or die;

/** @var JDocumentError $this */
if (($this->error->getCode()) == '404') {
header('Location: index.php?option=com_sppagebuilder&view=page&id=130');
exit;
}
---------------------
Attachments (1)
  1. more than a month ago
  2. Helix3
  3. # 10
Hello all,

the solution I am using:

1. create custom 404 page in pagebuilder
2. assign it to a hidden menu, so you are getting an url. I am using a menu called "hidden" which is hidden... in my example the name is 404
3. Edit the file error.php in your template root directory /templates/shaper_xxx/error.php. Just add the following code at the beginning of the file, see example (I used the standard error.php of joomla)

<?php
/**
* @package Joomla.Site
* @subpackage Template.system
*
* @copyright Copyright (C) 2005 - 2017 Open Source Matters, Inc. All rights reserved.
* @license GNU General Public License version 2 or later; see LICENSE.txt
*/

defined('_JEXEC') or die;

/** @var JDocumentError $this */
if (($this->error->getCode()) == '404') {
header('Location: /404');
exit;
}

4. Replace the /404 with the url of your pagebuilder page.

5. save the file.
done.

It will show as every normal content page, with your header and footer.


Thank you! question, how to disguise the url? not to show like "xxx.com/index.php?option=com_sppagebuilder&view=page&id=67" ??

and make it look just like /404
  1. more than a month ago
  2. Helix3
  3. # 11
Hello all,

the solution I am using:

1. create custom 404 page in pagebuilder
2. assign it to a hidden menu, so you are getting an url. I am using a menu called "hidden" which is hidden... in my example the name is 404
3. Edit the file error.php in your template root directory /templates/shaper_xxx/error.php. Just add the following code at the beginning of the file, see example (I used the standard error.php of joomla)

<?php
/**
* @package Joomla.Site
* @subpackage Template.system
*
* @copyright Copyright (C) 2005 - 2017 Open Source Matters, Inc. All rights reserved.
* @license GNU General Public License version 2 or later; see LICENSE.txt
*/

defined('_JEXEC') or die;

/** @var JDocumentError $this */
if (($this->error->getCode()) == '404') {
header('Location: /404');
exit;
}

4. Replace the /404 with the url of your pagebuilder page.

5. save the file.
done.

It will show as every normal content page, with your header and footer.


Thank you! question, how to disguise the url? not to show like "xxx.com/index.php?option=com_sppagebuilder&view=page&id=67" ??

and make it look just like /404


This worked perfectly for me. Thank you for posting this.
  1. more than a month ago
  2. Helix3
  3. # 12
Danke für die Antwort.

Schade ist immer. Das bei jeden Update der Code wieder überschrieben wird.

:(
  1. more than a month ago
  2. Helix3
  3. # 13
Danke für die Antwort.

Schade ist immer. Das bei jeden Update der Code wieder überschrieben wird.

:(


Hi there, Please write down your query via English Langauge. Thanks
  1. more than a month ago
  2. Helix3
  3. # 14
Danke für die Antwort.

Schade ist immer. Das bei jeden Update der Code wieder überschrieben wird.

:(


Hi there, Please write down your query via English Langauge. Thanks


he wrote in German
"It is always a pity. That with every update the code is again overwritten."
  1. more than a month ago
  2. Helix3
  3. # 15
The translation of "JERROR_PAGE_NOT_FOUND="Page not found" with a language override just doesn't work.

I simply don't understand, why Joomshaper (and a lot of other template / component builders) can't just stick to proper Joomla! standards.

Please make just sure, the entry of the according joomla! language.ini ist used in the error.php. It can't be our job as paying customers building bloody template overrides and even rebuild them after each update (which would be almost weekly).

It's quite obvious and not that much surprising that we need to customize the language and even the layout of the error pages. Why just enable more parameters in the template settings (where we can choose the error 404 logo)?

thank you.
  1. more than a month ago
  2. Helix3
  3. # 16
The translation of "JERROR_PAGE_NOT_FOUND="Page not found" with a language override just doesn't work.

I simply don't understand, why Joomshaper (and a lot of other template / component builders) can't just stick to proper Joomla! standards.

Please make just sure, the entry of the according joomla! language.ini ist used in the error.php. It can't be our job as paying customers building bloody template overrides and even rebuild them after each update (which would be almost weekly).

It's quite obvious and not that much surprising that we need to customize the language and even the layout of the error pages. Why just enable more parameters in the template settings (where we can choose the error 404 logo)?

thank you.


Hi there,

Thanks for your reply. Please read the documentation of the custom 404 page.

https://docs.joomla.org/Creating_a_Custom_404_Error_Page

-Thanks
  1. more than a month ago
  2. Helix3
  3. # 17
Hi there,

Thanks for your reply. Please read the documentation of the custom 404 page.

https://docs.joomla.org/Creating_a_Custom_404_Error_Page

-Thanks


Hi, Toufiq. This instruction is not very useful, as the standard error.php is already оverriden inside Helix. Thus, it makes sense to perform only the second part. And editing should be done every time after updating Helix. This is not very convenient, and this is exactly what Peter has indicated to you, and not how to do it.

You do not catch the essence of the user's question.

Peter,You can change the permissions for the error.php file that is inside the template by setting a ban on writing to 444. Thus, it will not change when the template is updated.
http://dl3.joxi.net/drive/2019/05/31/0008/0401/545169/69/7b352d3369.png
By the way, in the settings of the template it is possible to change the logo and background image.
http://dl3.joxi.net/drive/2019/05/31/0008/0401/545169/69/f58f4ebffe.png
  1. more than a month ago
  2. Helix3
  3. # 18
Hi there,

Thanks for your reply. Please read the documentation of the custom 404 page.

https://docs.joomla.org/Creating_a_Custom_404_Error_Page

-Thanks


Hi, Toufiq. This instruction is not very useful, as the standard error.php is already оverriden inside Helix. Thus, it makes sense to perform only the second part. And editing should be done every time after updating Helix. This is not very convenient, and this is exactly what Peter has indicated to you, and not how to do it.

You do not catch the essence of the user's question.

Peter,You can change the permissions for the error.php file that is inside the template by setting a ban on writing to 444. Thus, it will not change when the template is updated.
http://dl3.joxi.net/drive/2019/05/31/0008/0401/545169/69/7b352d3369.png
By the way, in the settings of the template it is possible to change the logo and background image.
http://dl3.joxi.net/drive/2019/05/31/0008/0401/545169/69/f58f4ebffe.png


Thanks :)
  1. more than a month ago
  2. Helix3
  3. # 19
Thanks Pavel for highlighting my true request ;-) and the hint with the permissions. I wasn't aware of this possibility and it makes the customizing more convenient, of course.

Concerning the settings in the backend: I already do know this settings and my request was more about, if JS could just enhance this section a bit (for example for an error text which is used instead of the default text, if entered) and more settings for the images (image size, links on the logo and so on). I guess not a big trick for you guys? Would be great, however.

Have a great start into the new week everybody & thanks for your support!
  1. more than a month ago
  2. Helix3
  3. # 20
Thanks Pavel for highlighting my true request ;-) and the hint with the permissions. I wasn't aware of this possibility and it makes the customizing more convenient, of course.


Hi. Another small life hack: Using the instructions from joomla.org provided by
Toufiq, you can create a 404 page with any design and text using the SP PB Page instead of the joomla article
  1. more than a month ago
  2. Helix3
  3. # 21


There are no replies made for this post yet.
Be one of the first to reply to this post!


This forum is archived

This forum has been archived. Please use JoomShaper official support system.