1. Stellar
  2. Thursday, 18 June 2020
i have a problem with my websites
Css don't load in all pages except the home page
Accepted Answer
Until yesterday everything was working nicely, what happened I don’t know,

As you know, I am not your Joomla nor Server manager. Sometimes it's beyond us.
Remember to check .htaccess files part about sef links and SEF settings in all domains.

If you changed PHP version, in some servers it clean content of .htaccess file and add there PHP version set only, no default Joomla code inside anymore. Maybe it was this case. If yes, change hosting company, you cannot trust them anymore.
  1. more than a month ago
  2. Stellar
  3. # Permalink
Responses (7)
in that case it was something else, also Joomla update didn't brake it.
  1. more than a month ago
  2. Stellar
  3. # 1
Maybe the reason aliases in Arabic. Try changing it into Latin.

Or turn ON it option

Attachments (2)
  1. more than a month ago
  2. Stellar
  3. # 2
Thank you sir for the great help always and I hope you are in the best condition

We are not a serious fact, because it touches many our websites for Arabic only, not English

I applied the steps

1) Rename htaccess.txt >> .htaccess
2) In General Configuration> SEO Settings> Use URL Rewriting: Yes

The problem is solved only in this site

https://www.hurghada-surgery.com/ar/education-ar/item/21-%D8%A7%D9%84%D8%AA%D8%AD%D8%B6%D9%8A%D8%B1 -% D9% 84% D9% 84% D8% AC% D8% B1% D8% A7% D8% AD% D9% 87

But the problem is still in other sites

Please adivece

https://keysintl.com/index.php/ar/%D8%A7%D9%84%D8%AF%D8%B9%D9%85-%D8%A7%D9%84%D9%81%D9% 86% d 9% 8a
https://sat-alex.com/index.php/%D8%A7%D9%84%D9%85%D9%82%D8%A7%D9%84%D8%A7%D8%AA-%D9% 88% D8% A7% D9% 84% D8% A7% D8% AE% D8% A8% D8% A7% D8% B1
https://www.orifacademyeg.com/index.php/%D8%A3%D9%83%D8%A7%D8%AF%D9%8A%D9%85%D9%8A%D8%A9-%D8% A3% D9% 88% D8% B1% D9% 8A% D9% 81% D9% 84% D9% 8A% D9% 85

It does not work properly except on the first page

Until yesterday everything was working nicely, what happened I don’t know, please help
  1. more than a month ago
  2. Stellar
  3. # 3
We would recommend reaching out to a Joomla developer or community of developers for additional assistance

Yes, but we are not Joomla Core Developers.

As you may (not?) know with SEO Rewriting enabled you shouldn't have links with "index.php" !!!

so do not click in old links, that one works:


please re-click whole menu again,
and update links that you added manually.
  1. more than a month ago
  2. Stellar
  3. # 4
It's a problem with your server configuration. You would have it also with Protostar template.

For sure:
1) Rename htaccess.txt >> .htaccess
2) In global configuration > SEO Settings > Use URL Rewriting: Yes
  1. more than a month ago
  2. Stellar
  3. # 6

There are no replies made for this post yet.
Be one of the first to reply to this post!

This forum is archived

This forum has been archived. Please use JoomShaper official support system.