1. Caterina
  2. Macro
  3. Saturday, 25 May 2019
Hi, I use MACRO template and on safari browser for iphone and for macbook, updated at last version, the off canvas menu seems to be always open but without click on it, (and it has a transparent background).

Please, see the images attached


Can you help me to fix this problem?
Thank you
Attachments (2)
Responses (10)
Accepted Answer Pending Moderation
Hi,
Thanks for your query. I found you've published the offcanvas module in bottom. http://prntscr.com/ntulv2
Please remove that and it'll solve the issue.

-Best Regards
  1. more than a month ago
  2. Macro
  3. # 1
Accepted Answer Pending Moderation
Hi, thanks for you reply.
How can i do that?
From module section seems to be ok: the menu module is publish in offcanvas position.

Thanks
Attachments (1)
  1. more than a month ago
  2. Macro
  3. # 2
Accepted Answer Pending Moderation
Please publish only one offcanvas module and select the language to all http://prntscr.com/nu9uu9
Or select different language for different offcanvas module http://prntscr.com/nu9vpw

-Thanks
  1. more than a month ago
  2. Macro
  3. # 3
Accepted Answer Pending Moderation
Hi, i tried to do that but the problem still exsists.
I also tried to disable all additional modules on canvas position and to enable only one menu (the desktop main menu) but nothing changes.
Before safari updating, all worked fine.
Thanls
  1. more than a month ago
  2. Macro
  3. # 4
Accepted Answer Pending Moderation
Please use this css into your custom css and let me know if that helps.

.offcanvas-menu .offcanvas-inner {
-webkit-transform-style: preserve-3d;
}


-Thanks
  1. more than a month ago
  2. Macro
  3. # 5
Accepted Answer Pending Moderation
Hi Sifat, unfortunately it doesn't work :(
  1. more than a month ago
  2. Macro
  3. # 6
Accepted Answer Pending Moderation
Hi Sifat, unfortunately it doesn't work :(

I didn't find the code anywhere in your files http://prntscr.com/nvtand. I think you replaced it in wrong place. Please follow this screencast and use this css there.

.offcanvas-menu .offcanvas-inner {
-webkit-transform-style: preserve-3d !important;
}
  1. more than a month ago
  2. Macro
  3. # 7
Accepted Answer Pending Moderation
Hi, we try the code con thepole.it, we try with important too but it doesn't work.

Than we deleted it; but if you want to check we reinsert the code on custom css.

Thanks
  1. more than a month ago
  2. Macro
  3. # 8
Accepted Answer Pending Moderation
Hi, we found what caused the problem:
all animation effects above the fold lets the error happens. So we disabled all animation effect for the row or the column or the addons that stays above the fold and the problem doesn't happen anymore. Also some slider's effects causes this problem. Do you think is there a way to fix this problem wothout disable the effects?
thanks
  1. more than a month ago
  2. Macro
  3. # 9
Accepted Answer Pending Moderation
Yes that's what i was thinking. Some animation may conflict. You need to disable those and that should resolve the issue.

-Thanks
  1. more than a month ago
  2. Macro
  3. # 10


There are no replies made for this post yet.
Be one of the first to reply to this post!


This forum is archived

This forum has been archived. Please use JoomShaper official support system.