1. Nasir Khan
  2. Salon
  3. Thursday, 17 October 2019
I was creating a new site using the Salon template. I installed the quick start and imported the contents. I tried to create the blog layout by modifying the category but it shows a broken layout.

Please advice how can i fix the issue.

Intent: http://demo.joomshaper.com/2018/salon/index.php/blog
Staging site: https://nasirkhn.info/nasirkhn/articles
Accepted Answer
Accepted Answer Pending Moderation
Hi there,

Thanks for your reply. Please follow the instructions.

Go to the file location
templates/shaper_salon/html/com_content/article/default.php
Find out the code

<div itemprop="articleBody">

And replce with this code

<div class="mid-content" itemprop="articleBody">


https://prnt.sc/pm49b8

Add this css code inside the custom.css file.

.mid-content {
width: 1140px;
margin: 0 auto;
}


-Thanks
  1. more than a month ago
  2. Salon
  3. # Permalink
Responses (9)
Accepted Answer Pending Moderation
Hi there,

Sorry for the inconvenience. Please remove the div, span, em HTML tag from your all item content area.

-Thanks
  1. more than a month ago
  2. Salon
  3. # 1
Accepted Answer Pending Moderation
Thanks for the solution. I did not notice this additional HTML code, as it was showing perfectly in the previous template.

Now i fount an another issue on the details page. There is margin/padding around the content of the details page, you can check the following page to get an idea about the issue.

Issue: https://nasirkhn.info/nasirkhn/articles/2018-11-29-06-24-49

Here i am creating default Joomla articles with no additional styling.
  1. more than a month ago
  2. Salon
  3. # 2
Accepted Answer Pending Moderation
thanks for the fix. I tried it earlier, but i was concerned if it will be replaced on the next theme update. So will it be replaced in the new theme update? or what will happen?

By applying the suggested changes, the texts are showing with margin but the below part of like tags and author profile is still the same as previous. how can i fix that?
  1. more than a month ago
  2. Salon
  3. # 3
Accepted Answer Pending Moderation
Hi there,

Thanks for your reply. We will fix it next update.

-Thanks
  1. more than a month ago
  2. Salon
  3. # 4
Accepted Answer Pending Moderation

By applying the suggested changes, the texts are showing with margin but the below part of like tags and author profile is still the same as previous. how can i fix that?


what to do with this?
  1. more than a month ago
  2. Salon
  3. # 5
Accepted Answer Pending Moderation
Hi there,

Thanks for your reply. Please add this CSS code inside the custom.css file.


.view-article .article-details .article-author-information {
width: 1140px;
margin: 0 auto;
}
ul.tags.list-inline {
width: 1140px;
margin: 0 auto;
}


-Thanks
  1. more than a month ago
  2. Salon
  3. # 6
Accepted Answer Pending Moderation
Hi there,

Thanks for your reply. Please add this CSS code inside the custom.css file.


.view-article .article-details .article-author-information {
width: 1140px;
margin: 0 auto;
}
ul.tags.list-inline {
width: 1140px;
margin: 0 auto;
}


-Thanks
  1. more than a month ago
  2. Salon
  3. # 7
Accepted Answer Pending Moderation
Hi,

I'm have applied the above fixes to the Salon template which have worked on a laptop browser.

I've been testing the posted articles on an iPhone using Safari browser.

When clicking on to one of the postings in the body of the posted article the text is being cut off on the right hand side and not truncating on to the next line.

There are also no side margins.

Please find link below:-

https://mg.netjoy.co.uk/index.php/insight/blog

Please advise,

kind regards

Nick
  1. more than a month ago
  2. Salon
  3. # 8


There are no replies made for this post yet.
Be one of the first to reply to this post!


This forum is archived

This forum has been archived. Please use JoomShaper official support system.