1. SP Page Builder 3.x
  2. Tuesday, 05 March 2019
Goodmorning,
I can't figure it out two things:
1. why when I make login in the front-end I get a blank page
2. why when in the pagebuilder I click on front-end edit I get a wrong url (then if I correct the url and make the login a blank page like point 1)

The website is https://cabe.marcopenitenti.it and the copy on the right domain: https://cabemilano.com
Both have Joomla 3x last versione, pagebuilder and template joomshaper shaper_spetctrum last versione. In the first domain there is php 7.x in the second one php 5.5 for now. Some identical problem on both.

Error Log:
Notice: Constant K2_JVERSION already defined in /home/ufvi5vl0/domains/http://cabemilano.com/public_html/plugins/system/k2/k2.php on line 21
Fatal error: Call to undefined method JEventDispatcher::getContent() in /home/ufvi5vl0/domains/http://cabemilano.com/public_html/plugins/editors-xtd/readmore/readmore.php on line 44

This is what happens on the first site:
Notice: Constant K2_JVERSION already defined in /home/lhjupqcg/http://cabe.marcopenitenti.it/plugins/system/k2/k2.php on line 21
logo

OH CRAP!

Call to undefined method JEventDispatcher::getContent()

Any Idea,
thanks.

m.
Accepted Answer
The more extra plugin you would install then harder to find a reason of problems.
The "Readmore" plugin was a basic example.
Smart method:
Disable extra installed plugins one by one, to check one which makes a mess.
---
Using PHP 5.5, PHP 5.6, PHP 7.0 is not recommended anymore.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # Permalink
Responses (9)
Hi,
1) please contact with K2 and JEvent component support.
2) K2 was not overridden in Spectrum template.
3) beside PHP 5.5 is not supported anymore, by nobody.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 1
Hello,
3) PHP5.5 is temporary on a server, the other one is PHP7 (as you can see from my message) so that is not the problem.
2) Sorry, I don't understand, I cannot use Spectrum template and K2 together? What is the exact meaning by K2 was not overridden in Spectrum template?
1) The first error of K2 is not blocking the website, I'll try to figure it out.
The JEventDispatcher::getContent() may be yes, but I didn't install JEvent, As matter of fact I think JEventDispatcher is by Joomla! Event Dispatcher and not JEvent.

The front-end login worked at the beginning, I don't use it often so I don't know when it broken. Oh, I also have the falang plugin (I try to write to them too).

It's urgent for me to solve it. Any further help is appreciated.

Thanks,
Marco
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 2
On version with PHP7 I can't see the debug on the bottom of the "OH CRAP" Page and I can't see the second error link.
On version with PHP5 I see the following line:

Fatal error: Call to undefined method JEventDispatcher::getContent() in /home/ufvi5vl0/domains/http://cabemilano.com/public_html/plugins/editors-xtd/readmore/readmore.php on line 44

It calls JEventDispatcher as undefined method inthe editor-xtd readmore.php file which is relate to you I think.

Now if I can find the plugin I try to disable it.

Any suggestion?

Thanks,
Marco
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 3
I found out that if I dispable the readmore plugin (which is a core funcion of joomla) the error dissapear, beside I've discovered that if I change the template with a Joomla! one, the error dissapear.

m.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 4
If I disable K2, the website comes back.

It happens only if I login in in the front-end, otherwise it works.

Even disabling K2 or changing the template there is no more the JEventDispatcher error, but I can't navigate the website, I only see the profile page.

I keep testing, but I'm kind of lost...
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 5
Update: I've resolved the navigation thing. I only had to accept the privacy from the front-end profile.

So the situation is:
1) If I disable K2 it works (but I've use it for the catalog
2) If I change the template Spectrum it works, but naturally it's ugly.

Any idea on the conflict?

Thanks,
m.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 6
I've Got it!

I have re-enabled the k2 component and it worked in the front-end again. So the problem is the profile page, it wasn't loading, I don't know why. As soon as I accepted the privacy, the profile page is not loading anymore, and now is working.

If I point to the profile page: index.php/it/your-profile/profile?layout=edit again I have the OH CRAP page with the same error.

Now is not urgent anymore, but if anyone has an idea it would be appreciated.

Thanks,
Marco
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 7
I found out that if I dispable the readmore plugin (which is a core funcion of joomla) the error dissapear, beside I've discovered that if I change the template with a Joomla! one, the error dissapear.

m.

THANK YOU !! That worked
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 8


There are no replies made for this post yet.
Be one of the first to reply to this post!


This forum is archived

This forum has been archived. Please use JoomShaper official support system.