1. Steve
  2. SP Page Builder 3.x
  3. Friday, 13 July 2018
Up until I installed the latest version of the software (3.2.5), parallax backgrounds were working fine. Now they're not. Checked all the usual caches and cookies.

Anyone else experience this?
Accepted Answer
Accepted Answer Pending Moderation
You're welcome.
Yes, today update SPPB Pro 3.2.6 fixed issue. sorry that you had to wait 5 days.
---
Quick tip:
Check settings of Row background image. Clear cache etc.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # Permalink
Responses (27)
Accepted Answer Pending Moderation
Yes, same issue
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 1
Accepted Answer Pending Moderation
I have exactly the same
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 2
Accepted Answer Pending Moderation
Guys, could you mention the template name? We changed parallax system and we saw that some of our users faced trouble. Hope we will provide the solution by Monday or Tuesday. Thanks for patience.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 3
Accepted Answer Pending Moderation
Guys, could you mention the template name? We changed parallax system and we saw that some of our users faced trouble. Hope we will provide the solution by Monday or Tuesday. Thanks for patience.


I'm using Helix Ultimate template. See https://www.joomshaper.com/forums/background-sections-are-not-working-properly-after-update-sp-page-builder-to-3-2-5
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 4
Accepted Answer Pending Moderation
Same here. Helix Ultimate. Page Builder 3.2.5
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 5
Accepted Answer Pending Moderation
Yes, same issue. Helix Ultimate 1.0.2 , PageBuilder Pro 3.2.5, no custom CSS.
Example Test; If you create a new page using sample section templates without any edits, the bg image is shown and parallax works. Once you change the default backgrounds to a new image and save, it breaks with only a white bg being shown.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 6
Accepted Answer Pending Moderation
Yes, same issue. Helix Ultimate 1.0.2 , PageBuilder Pro 3.2.5, no custom CSS.
Example Test; If you create a new page using sample section templates without any edits, the bg image is shown and parallax works. Once you change the default backgrounds to a new image and save, it breaks with only a white bg being shown.


The problem is that the related background data-image-src path is not being formed correctly when parallax is enabled.

In the latest SPP build, when parallax is turned on, the code will build the image path reference relative to the spp component path, where your image probably does not reside and results in; https://www.misahualliamazonlodge.com/index.php/component/sppagebuilder/images/pictures/img_toucan_org.jpg

A quick end user fix, until the code correction comes out, is the following;
in the Row Options, Style, Background Image location path, you can either prefix with "/" or enter the complete URL;

after prefixing with a "/"
/images/pictures/img_toucan_org.jpg (corrects the issue)
This ensures reference to the web root path.
https://www.misahualliamazonlodge.com/images/pictures/img_toucan_org.jpg
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 7
Accepted Answer Pending Moderation
Yes, same issue. Helix Ultimate 1.0.2 , PageBuilder Pro 3.2.5, no custom CSS.
Example Test; If you create a new page using sample section templates without any edits, the bg image is shown and parallax works. Once you change the default backgrounds to a new image and save, it breaks with only a white bg being shown.


The problem is that the related background data-image-src path is not being formed correctly when parallax is enabled.

In the latest SPP build, when parallax is turned on, the code will build the image path reference relative to the spp component path, where your image probably does not reside and results in; https://www.misahualliamazonlodge.com/index.php/component/sppagebuilder/images/pictures/img_toucan_org.jpg

A quick end user fix, until the code correction comes out, is the following;
in the Row Options, Style, Background Image location path, you can either prefix with "/" or enter the complete URL;

after prefixing with a "/"
/images/pictures/img_toucan_org.jpg (corrects the issue)
This ensures reference to the web root path.
https://www.misahualliamazonlodge.com/images/pictures/img_toucan_org.jpg



This did not work for me. I tried both the entire url and the "/" before the path and it is still not working. Helix Ultimate template.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 8
Accepted Answer Pending Moderation
The only other real thing that I could have you check is your ultimate template advanced settings. If you are compressing java script you might want to excluded the following;
main.js,sppagebuilder.js,jquery.min.js

I have found a variety of issues occur if these are not excluded.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 9
Accepted Answer Pending Moderation
Hi Lyle,

I am not compressing javascript or css. Another interesting observation: If I disable parallax and do add the / in the url, i.e., "/images/2018/05/03/jerryleelewisstarclub.jpg" it also does not work. Right now it is working with Parallax disabled and using the following url for the background image: images/2018/05/03/jerryleelewisstarclub.jpg

http://wadesnyder.com/

Oh well, hopefully a fix is on the way.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 10
Accepted Answer Pending Moderation
Can anyone send me admin access and let me check the issue.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 11
Accepted Answer Pending Moderation
same on mine..
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 12
Accepted Answer Pending Moderation
same issue for me using latest SP release and Helix Ultimate. Adding the "\" before the image path did not fix it.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 13
Accepted Answer Pending Moderation
same issue for me using latest SP release and Helix Ultimate. Adding the "\" before the image path did not fix it.
I tried "/" and it didn't work. Sorry for the typo.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 14
Accepted Answer Pending Moderation
Experiencing the same issue using Melvin. It still persists when I turn off "parallax background". Interestingly, it appears to work when using the front page editor, but not when previewing or viewing the page. See attached.[attachment]Screen Shot 2018-07-16 at 11.44.13 AM.png[/attachment]
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 15
Accepted Answer Pending Moderation
Can anyone send me admin access and let me check the issue.
Are you still looking for admin access? I can DM you mine.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 16
Accepted Answer Pending Moderation
Can anyone send me admin access and let me check the issue.
Are you still looking for admin access? I can DM you mine.


Thanks for your assistance. Right now, we don't need further admin access. Hope we will release fix tomorrow. Parallax system is very complex when you have to support several devices at the same time. We are working to make more efficient parallax in the best possible way.

Thank You
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 17
Accepted Answer Pending Moderation
I installed the latest update and it appears to be working now! I had to remove the image, save it, and re-add it back for it to appear though. Thanks for the prompt resolution!
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 18
Accepted Answer Pending Moderation
Yes. Working again. Thanks.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 19
Accepted Answer Pending Moderation
No, it does not work properly - fixed one bug returned another bug https://www.joomshaper.com/forums/how-to-fix-parallax#reply-149904
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 20
Accepted Answer Pending Moderation
@Pavel , it's old Chrome bug.
This should help:


.sp-page-builder .sppb-section { will-change: transform;}

---
Source from 2015: https://www.fourkitchens.com/blog/article/fix-scrolling-performance-css-will-change-property/


btw
I wonder which value is better transform or auto ??
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 21
Accepted Answer Pending Moderation
@Pavel , it's old Chrome bug.

Hi, Paul. No, it's not. I practically do not use Chrome. The background does not disappear, but shifts
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 22
Accepted Answer Pending Moderation
Today I was able to fix that problem using only Row settings and above custom css line.
But I agree that feature still needs small improvements and using a high images. I hope upcoming update will bring more fixes. Thanks for review.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 23
Accepted Answer Pending Moderation
Last update SPPB 3.2.6 works great to me. Thanks a lot to the staff.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 24
Accepted Answer Pending Moderation
Last update SPPB 3.2.6 works great to me.

Must be you just did not use it in the mode in which it works badly
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 25
Accepted Answer Pending Moderation
yes, some people are just lucky.
  1. more than a month ago
  2. SP Page Builder 3.x
  3. # 26


There are no replies made for this post yet.
Be one of the first to reply to this post!


This forum is archived

This forum has been archived. Please use JoomShaper official support system.