1. Aspasia
  2. Wednesday, 04 May 2016
Hello Team,

I am working on a new project and took this fairly new template design for my client. I installed the quickstart package and found everything working smoothly. However I started noticing that the sticky menu on the top that is suppose to float across is not functioning and does not float.The following are the nly changes that I made:

1. Uninstalled all Hikashop related extensions
2. Installed/Upgraded SP Page Builder from V 1.0.8 to V 1.0.9

Site URL: http://momentera.zaha.in/
Joomla Version: 3.5.1
SP Page Builder Version: V 1.0.9

Can you please help me fix this issue.

Regards,
Syed H
Accepted Answer
Hi,

Thanks for your query. We have made fixed for you guys. Please download attachment & replace below directory.

aspasia/templates/shaper_aspasia/js

-Thanks
Attachments (1)
  1. more than a month ago
  2. Aspasia
  3. # Permalink
Responses (26)
Hi Syed,

Aspasia quick start pack comes with the main menu set up sticky out of the box, which means that it is you, sir, who somehow introduced the issue into your system. Please roll back your site using backup of its last well working version. In case you failed creating a backup, please start from scratch, only this time creating backups and testing as you go along.

Regards,

Alex
  1. more than a month ago
  2. Aspasia
  3. # 1
Alex,

Thank you for your input. It was working fine, however the moment I updated the SP Page Builder from V1.0.8 to V1.0.9 this started.

Any suggestions?

Regards,
Syed H
  1. more than a month ago
  2. Aspasia
  3. # 2
Paul,

I have checked that setting the first thing when I felt there was a problem. I tried to toggle the setting several ties without any good luck.
Since I did not go too far in development, I just removed everything and installed the QS again.

I will make moves very carefully and will add any of my findings if I face this issue again.

Let us not mark this issue closed as of now, and hold it until tomorrow. I will revert at the earliest by EOD tomorrow.

A big thank you to Alex and Paul for staying around.

Best Regards,
Syed H
  1. more than a month ago
  2. Aspasia
  3. # 3
@ Pawel, @ Syed,

Gents, I've just managed to replicate the same issue: uninstalling Hikashop and its extensions leads to the header becoming non-sticky, despite the stickiness being set to "Yes" at the back end, just like Syed reported.

I am referring this bug to our core developers now. Please bear with us while we are addressing this, Syed.

Regards,

Alex
  1. more than a month ago
  2. Aspasia
  3. # 4
Well,

Here is what I found so far.

Phase 1:
1. Installed QS and found everything working OK
2. Removed all Hikashop extensions
3. Tested the front end and found the sticky menu out of order.

Phase 2.
1. Installed QS and found everything working OK
2. Removed all K2 Extensions
3. Tested the front end and found the sticky menu working well.
4. Removed all disabled extensions (Disabled under the QS) of Hikashop
5. Tested the front end and found the sticky menu working well.
6. Disabled Hikashop extensions 1 at a time and tested the front end to locate the extension that is creating this problem.
7. After testing all of them I found the issue only with the Module "HikaShop Cart Module". Disabling this module is breaking the functionality of the sticky menu.

Now, If I keep "HikaShop Cart Module" enabled the sticky menu works. The moment I disable it, it stops floating.

For now I have hidden it using the following under Custom CSS:

.top-cart-wrapper {
position: relative;
display: inline-block;
float: right;
visibility: hidden;
}


We don't need to have that cart Icon, what do we do now.

This was an extensive study and I found the root cause, kindly help me deal with this.

Regards,
Syed H
  1. more than a month ago
  2. Aspasia
  3. # 5
I can reproduce exactly what Syed Shah Zahurullah Hussaini says. I have the same problem.
  1. more than a month ago
  2. Aspasia
  3. # 6
please be patient, we are working to fix it asap. thanks.
--
In meantime please focus on site content , modules etc...
  1. more than a month ago
  2. Aspasia
  3. # 7
@TISSERAND,

Thank you for your feedback, really appreciate it. As Pawel said, our core developers are working to fix this issue. So, please bear with us in the meantime.

Regards,

Alex
  1. more than a month ago
  2. Aspasia
  3. # 8
Has anyone worked out how to turn remove Hikashop from this template without it effecting other css / addons / extensions?
  1. more than a month ago
  2. Aspasia
  3. # 9
@Jimbo,

For now, just hide it using the CSS Code I have sent in the earlier post. Let us wait for Alex to get this fixed.
We have done a thorough study and found what is conflicting, now just wait and watch.

Hope this helps for now.

Regards,
Syed H
  1. more than a month ago
  2. Aspasia
  3. # 10
Jimbo! wrote:

Has anyone worked out how to turn remove Hikashop from this template without it effecting other css / addons / extensions?


This issue will be fixed in next week, please wait, and focus on more important things like content on your site :) Thanks.
  1. more than a month ago
  2. Aspasia
  3. # 11
Paul Frankowski wrote:

Jimbo! wrote:

Has anyone worked out how to turn remove Hikashop from this template without it effecting other css / addons / extensions?


This issue will be fixed in next week, please wait, and focus on more important things like content on your site :) Thanks.


Paul, do we have any updates on this one?

Best Regards,
Syed H
  1. more than a month ago
  2. Aspasia
  3. # 12
Hi Alex is there and update from your core developers yet on this?
  1. more than a month ago
  2. Aspasia
  3. # 13
Hi Syed,

Did you try to implement the fix, attached in Toufiq's last reply in this thread?

Have a nice week.

Regards,

Alex
  1. more than a month ago
  2. Aspasia
  3. # 14
Hi,

I have replace the file but still not working.

-Thanks
  1. more than a month ago
  2. Aspasia
  3. # 15
Hi, Please enable less compile from template manager. Then try again & let me know. Thanks
  1. more than a month ago
  2. Aspasia
  3. # 16
Well,

Here is what I found so far.

Phase 1:
1. Installed QS and found everything working OK
2. Removed all Hikashop extensions
3. Tested the front end and found the sticky menu out of order.

Phase 2.
1. Installed QS and found everything working OK
2. Removed all K2 Extensions
3. Tested the front end and found the sticky menu working well.
4. Removed all disabled extensions (Disabled under the QS) of Hikashop
5. Tested the front end and found the sticky menu working well.
6. Disabled Hikashop extensions 1 at a time and tested the front end to locate the extension that is creating this problem.
7. After testing all of them I found the issue only with the Module "HikaShop Cart Module". Disabling this module is breaking the functionality of the sticky menu.

Now, If I keep "HikaShop Cart Module" enabled the sticky menu works. The moment I disable it, it stops floating.

For now I have hidden it using the following under Custom CSS:

.top-cart-wrapper {
position: relative;
display: inline-block;
float: right;
visibility: hidden;
}


We don't need to have that cart Icon, what do we do now.

This was an extensive study and I found the root cause, kindly help me deal with this.

Regards,
Syed H


Hi there,

i've a solution for the hikashop/sticky menu problem.
I uninstalled hikashop with all modules, plugins etc. too. Now my sticky menu and some other things like slides etc. doesn't work.

The problem is, that hikashop has some jquery scripts which after uninstall component are missing.

The solution is, that you can install the plugin called "jQuery easy" ( http://www.simplifyyourweb.com/downloads/jquery-easy ). You need to setup some things like this:

jQuery Version: 3.2.x
jQuery Migration: 3.0.0
jQuery UI: 1.8 (latest version)

Now you can use the Aspasia template without the hikashop component.

Cheers,
Mickman
  1. more than a month ago
  2. Aspasia
  3. # 17
Well,

Here is what I found so far.

Phase 1:
1. Installed QS and found everything working OK
2. Removed all Hikashop extensions
3. Tested the front end and found the sticky menu out of order.

Phase 2.
1. Installed QS and found everything working OK
2. Removed all K2 Extensions
3. Tested the front end and found the sticky menu working well.
4. Removed all disabled extensions (Disabled under the QS) of Hikashop
5. Tested the front end and found the sticky menu working well.
6. Disabled Hikashop extensions 1 at a time and tested the front end to locate the extension that is creating this problem.
7. After testing all of them I found the issue only with the Module "HikaShop Cart Module". Disabling this module is breaking the functionality of the sticky menu.

Now, If I keep "HikaShop Cart Module" enabled the sticky menu works. The moment I disable it, it stops floating.

For now I have hidden it using the following under Custom CSS:

.top-cart-wrapper {
position: relative;
display: inline-block;
float: right;
visibility: hidden;
}


We don't need to have that cart Icon, what do we do now.

This was an extensive study and I found the root cause, kindly help me deal with this.

Regards,
Syed H


Hi there,

i've a solution for the hikashop/sticky menu problem.
I uninstalled hikashop with all modules, plugins etc. too. Now my sticky menu and some other things like slides etc. doesn't work.

The problem is, that hikashop has some jquery scripts which after uninstall component are missing.

The solution is, that you can install the plugin called "jQuery easy" ( http://www.simplifyyourweb.com/downloads/jquery-easy ). You need to setup some things like this:

jQuery Version: 3.2.x
jQuery Migration: 3.0.0
jQuery UI: 1.8 (latest version)

Now you can use the Aspasia template without the hikashop component.

Cheers,
Mickman


Thanks for the suggestion. It worked for us. I tried replacing the file provided by Toufiq but unfortunately it only fixed the problems in the home page.
  1. more than a month ago
  2. Aspasia
  3. # 18
Hi,

Thanks for your query. We have made fixed for you guys. Please download attachment & replace below directory.

aspasia/templates/shaper_aspasia/js

-Thanks


Hello,

It only worked on the home page so I tried the jQuery easy plugin as suggested by Michael von Kannen at the bottom of this thread and it fixed the problem...But please fix this in the template itself.
Regards,

Marina
  1. more than a month ago
  2. Aspasia
  3. # 19
Hi,

Thanks for your query. We have made fixed for you guys. Please download attachment & replace below directory.

aspasia/templates/shaper_aspasia/js

-Thanks


Hello,

It only worked on the home page so I tried the jQuery easy plugin as suggested by Michael von Kannen at the bottom of this thread and it fixed the problem...But please fix this in the template itself.
Regards,

Marina


Hi there,

We will fix the motools problem in the next update.

-Thanks
  1. more than a month ago
  2. Aspasia
  3. # 20
Hi,

Thanks for your query. We have made fixed for you guys. Please download attachment & replace below directory.

aspasia/templates/shaper_aspasia/js

-Thanks


Hello,

It only worked on the home page so I tried the jQuery easy plugin as suggested by Michael von Kannen at the bottom of this thread and it fixed the problem...But please fix this in the template itself.
Regards,

Marina


Hi there,

We will fix the motools problem in the next update.

-Thanks


When are you planning to fix this? If you import page templates, the menu doesn't work either. I forgot to mention that so this is a serious issue.
Thanks!
  1. more than a month ago
  2. Aspasia
  3. # 21
Mootools problem, we don't have to....

Joomla 4.0 will kick off this useless library soon.
  1. more than a month ago
  2. Aspasia
  3. # 22
Mootools problem, we don't have to....

Joomla 4.0 will kick off this useless library soon.


And I just noticed that mouse wheel scrolling is not working either (Chrome only).
How do we fix that?

Regards
  1. more than a month ago
  2. Aspasia
  3. # 23
Have you checked on 2nd laptop with Chrome installed ?

p.s.
Chrome on Mac is always handicapped.
  1. more than a month ago
  2. Aspasia
  3. # 24
Have you checked on 2nd laptop with Chrome installed ?

p.s.
Chrome on Mac is always handicapped.

Yes, on a different computer (Chrome, Chrome Canary, FF).
I'm giving up on this template. Too many issues. I would like to try it once again when all its problems are solved though.
Regards
  1. more than a month ago
  2. Aspasia
  3. # 25


There are no replies made for this post yet.
Be one of the first to reply to this post!


This forum is archived

This forum has been archived. Please use JoomShaper official support system.