1. Optima
  2. Monday, 09 December 2013
I am using the Optima template on Joomla 3.2 with Helix II version 2.1.3

The default template manager settings in Advanced tab have LESS enabled and there is no custom.css file to make style changes that are not lost in a template update.

I created a custom.css file in .../templates/shaper_optima/css and added some style change code but they did not work, however when I add the same style change code directly into the bottom of the ..../templates/shaper_optima/css/template.css the changes were made correctly.

I am concerned I may lose the changes I have made during a future version update of the template, what is the correct process to make style changes in Optima with Helix II framework to avoid losing them in future updates?
Responses (11)
I have the same problem with Venus template. Although there is custom.css file, but it's placed above template.css file in head tag. That is why template.css styles has highest rank in hierarchy.

I think custom.css should be place below template.css. For now I will change it by myself, but there should me an upgare to fix this.
  1. more than a month ago
  2. Optima
  3. # 1
Create custom.less file on less folder and @import it master.less file.
  1. more than a month ago
  2. Optima
  3. # 2
Riyadh, I have followed the above instructions and created the custom.css file inside of less folder. Where do I reference the page and How to get there. I have been reading tones of stuff on this forum and feel like getting closer. I just want to customize css. By the way, the above statement says "Create custom.less file on less folder and @import it master.less file. ", I got confused on the @import it master.less ... can u alaborate? Thanks.
  1. more than a month ago
  2. Optima
  3. # 3
Hi,
First create a less file inside the less folder, like (custom.less), then open master.less file and add this code at the bottom :

@import 'custom.less';
  1. more than a month ago
  2. Optima
  3. # 4
Hello,
I am facing some issue too. I have uploaded the custom.css in /public_html/templates/shaper_helix3/css in order to see 2 CSS changes, but it is not working. Also, if I modify the Presets in Style's options, it is not working again. I have NOT enabled LESS and ANY Compressions.

If I add the changes at the Custom Code TAB, in Style options, it is working.

How can I eneable the custom.css please?
  1. more than a month ago
  2. Optima
  3. # 5
Yes, I am pretty sure that you forgot close } or missing dot or not completed class structure
---
Q: have you ever used this tool
Attachments (1)
  1. more than a month ago
  2. Optima
  3. # 6
BTW
Sometimes you should:
1) Test your code online with Inspector tool (built-in in any modern browser)
2) Then add into custom CSS field to make sure that is right
3) Then copy it into custom.css file
---
Believe me even I done it many times ;)
---
(!) Clear browser cache!
  1. more than a month ago
  2. Optima
  3. # 7
Hello Paul,
I work always with Inspector, both in Firefox and Chrome. Also, I wrote that the same code is working in the Custom Code TAB, in Style options, where it is working.

I have entered two lines.

.sp-megamenu-parent >li >a {
display: inline-block;
padding: 0 15px;
line-height: 90px;
font-size: 16px !important;
text-transform: uppercase;
letter-spacing: 1px;
color: #000;
}

.post-format {
background: #08b916;
}
  1. more than a month ago
  2. Optima
  3. # 8
we talk about Helix II or Helix3 this time?
  1. more than a month ago
  2. Optima
  3. # 9
Helix3 please.
  1. more than a month ago
  2. Optima
  3. # 10
if your custom.css file is inside /css/ folder it should be loaded
---
check also its file rights -- 644 in most cases
  1. more than a month ago
  2. Optima
  3. # 11


There are no replies made for this post yet.
Be one of the first to reply to this post!


This forum is archived

This forum has been archived. Please use JoomShaper official support system.